Lenovo T490 full freezes with Qubes 4.2

Hi there,

on Friday I tried to upgrade in-place (from 4.1) to Q4.2. Within Q4.2 the T490 then had several full freezes (screen is shown as normal, but no reaction to mouse movement or keystrokes at all).
Sometimes the system froze again right during forced reboot of the system, sometimes it was functional for hours until the next full freeze. Looking at journalctl I did not notice a recognizable pattern of log entries before the freeze - which may obviously be caused by the freeze to block the logged lines from being written to disk.

So I decided to give Q4.2 a second chance with a clean install (and import of appVMs). Sadly, I noticed the same kind of freezes. Now I replaced the M.2 and installed Q4.1 again, restoring a backup from friday. I did not notice freezes since then, but I only used the device for a few hours yet.

It looks like there is some compatibility problem of T490 and Q4.2. As looking at the logs did not help I have no idea how to debug this issue, so I write this here. As you know there will be now Q4.1 updates after this summer, so I obviously need to transition to Q4.2 somehow


Maybe related issue:

1 Like

Interestingly, there is a report of T490 failing to install at all at a specific step - I did not have issues during the Q4,2 setup on my T490

Thanks. When the Q 4.2 is bootable again I’ll try that kernel parameter.

ok, so I added the parameter to what I think is the xen commandline in /boot/grub2/grub.cfg right (before ${xen_rm_opt}, seperated by spaces ) How can I verify that the running system actually has hwp=off active?

Check scaling_driver in the output of this command in dom0 terminal:
xenpm get-cpufreq-para

I get “failed to get cpufreq parameter” for CPU 1,3,5 and 7-15.
4 report acpi-cpufreq (I assume core 0,2,4,6).

The system has 4 physical cores. As qubes disables SMT for security reasons 4 cores is what I expected. likely 1,3,5,7 are the disabled SMT-cores, but I have no idea where 8-15 are from?!

With hwp enabled the scaling_driver would be hwp-cpufreq, since your scaling_driver is acpi-cpufreq it means hwp is disabled.

perfect, thank you. Any idea why 16 cpus are listed?

No idea.

Ok. Thank you. I’m curios to see whether freezing is solved for T490 as well.

This solved the freezing for me, however it takes a noticeable amount of energy. With Qubes 4.1 after 3h of Idle I have about 60% battery remaining, with Qubes 4.2 and this Xen tweaks its down to about 40%.

You can report the issue here: