Lenovo P1 Gen 4 - Cant install - Pane is dead etc


I tried using my portable SSD’s with qubes-whonix on to use the operating system but I believe they do not work due to not being able to enable legacy mode on the new(ish) P1 Gen 4 Lenovo laptop…

I am getting the Not asking for vnc / x startup failed, aborting installation / pane is dead error when trying to do a fresh installation instead. I have disabled fast/secure boot. I have tried different USB’s and different methods of copying the qubes installation to USB to no avail.

I am pretty sure the problem is due to my nvidia dGPU. Unfortunately there is no way to disable the dGPU entirely in BIOS.

My problem is that I cannot enter ‘edit mode’ by pressing Tab when I reach the GRUB menu. Nothing happens when I press Tab at the GRUB menu where I can choose Qubes installation, rescue qubes installation, etc.

Therefore I cannot add those two lines in edit mode.

Does anyone have any suggestions?

Does anyone have any idea?

I don’t want to start a new thread with ‘cant enter edit mode during installation’ but feel that might get better help?


I just had to do this yesterday. So the troubleshooting guide is a bit confusing. You need to highlight the first selection and press e to get into edit mode. Then add the parameters after the word quiet on the second last line. Press control +x to boot!

Also you can ignore the legacy mode, it’s not supported on the newer Lenovo devices. It works fine as long you add the parameters in Grub.

This worked, thanks!

I have a new problem with the actual install now though haha.