Leaving space on disk after installation

Hi, so I recently got a new 1 TB SSD, and I wanted to install Qubes to only part of it, but I couldn’t figure out how to do this in the installer. When I used the Automatic installer it uses the full disk space. I then tried the Custom installer, and since I didn’t know what partitions to make I selected the “Click here to create them automatically”. I tried to resize the vm-pool partiton, but it complains about it not having a mount point, which I assume is intentional. I also can’t recreate the partition because it needs a mount point when making the partition. Any idea how to make the installer make a smaller partition? Thanks.

Installer of Qubes OS is not good with custom partitions, unstable. It was crashing all over the place in R4.0 if you do something non-standard with partitions. It still is not good, I faced issues with custom partitioning in R4.1, too.

My advice to try this:

  • create partition table (GPT type) and reserve the space you need by creating a temporary partition at location you need.
  • Format partition in NTFS or shred with random data to be sure Qubes OS installer will not affect it.
  • During installation you should use “Create them automatically” and it will occupy all empty space without your manual work.
  • And later you can remove this temporary partition and get the place for anything you want there, including multiple partitions if you want.
1 Like

Make sure that you do not select the option to recover disk space,or
your efforts will be in vain.
Qubes uses the Fedora installer, warts and all. I dont find it as bad as
balko, but YMMV.

It is not bad per se, it is just problematic for custom partitioning.
So, most of users of Fedora and Qubes OS do not face the issues I was struggling with.

Okay. I’ll try that later today. I think I’ll only need about 100 GiB for Qubes (It is not my main OS), so I guess I’ll make a ~900 GiB partition, format it as NTFS, then use the automatic installer. I’ll post an update once I do that. Thanks!

This worked. Thanks!

1 Like