Last few sys-gui issues I can't figure out - Anyone run into these?

Sorry for the long post.

Been playing with Qubes for a while off and on. But now I’m trying to get it up and configured to try to use it as a daily driver. Also a bit of a newb for than the most basic commands in Linux without a step by step guide. But I wanted to start my conversion with a distribution that truly had my interest and was something I would love to use daily for both security and privacy combined with other solutions I could cook into some vm’s :slight_smile:

So the ISO I use for Qubes 4.1 clean install was downloaded probably 3 weeks ago, and everything is up to date, dom0 all templates etc. Qubes 4.1 out of the box has worked perfectly, haven’t found anything that didn’t function.
And after a lot of searching and working out the kinks, sys-gui-gpu is working (mostly).
I have a few issues that I’ve given up on figuring out myself. I’m hoping someone might have run into some of them at least.

I submitted bug reports as I couldn’t find them mentioned anywhere.
Just curious if anyone ran into any of these and resolved them.

  1. I’m putting this one as first on the list because perhaps it’s a sign of the problem causing many of the other issues?
    Whenever a vm’s starts or shuts down I see an error notification:
    “Failed to execute qubes.WindowUpdater (from somevm-xx to dom0)”
    I’m assuming this MAY be a sign of some permissions that may not have been setup properly by the salt script? The only change I made to it was changing dummy-psu-dom0 to dummy-psu-sender on one line toward the beginning of the script.
    I also noticed shutdown looks like it only shuts down sys-gui, I have to tap the power button to fully shutdown. And open console on any VM’s either does nothing or crashes Qubes manager. These seem to lead me to permissions again?

  2. My “devices” icon is there but it’s blank, I just see a tiny empty bubble when I click on it.
    sys-usb is starting normally and dom0 see’s my devices, normally I would see my built in mic and webcam, however sys-gui see’s nothing. I tried some external devices:

  • USB storage devices nothing
  • USB wireless keyboard/mouse receiver was the only sign of life I’ve seen I got a message: “Denied qubes.InputKeyboard from sys-usb to dom0”
    So sys-usb is talking to sys-gui-gpu on some some level.
  1. The application or start menu if you will missing all my VM’s I figured out digging around and refreshed the applications on my templates. However some of the templates report missing applications after refreshing which I didn’t find and answer to anywhere, some general information that didn’t help but nothing Qubes specific.
  • whonix-ws-16 missing: Thunar.desktop
  • whonix-gw-16 missing 3: Thunar.desktop, gateway-firewall30default.desktop, gateway-firewall50user.desktop
  • fedora-34-xfce missing: org.mageia.dnfdragora.desktop
  • fedora-34 missing: gpk-update-viewer.desktop
  1. An annoying but not critical issue is the Power manager icon and power notifications are dead in the sys-gui-gpu interface, work fine in dom0.
    If I enable and disable the power manager icon in power manager settings I see the icons flash as if something is being added but it never shows up. I checked panel settings on all items and don’t see everything there looks fine

Thanks everyone in advance for any help.

-Kenny

1 Like

Thanks for detailed list, and also for creating issues on github for this! This is exactly the kind of help we need to stabilize this experimental feature!

I responded to most of the above in github issues already.

Try refreshing applications from cmdline using qvm-sync-appmenus <template-name> - you should get messages about failed menu entries - hopefully with a reason why.

1 Like

I’m happy I can contribute something, I felt like a jerk submitting 4 of them but I had just gotten sys-gui-gpu working with audio after a few attempts and wanted to post any issues while they were fresh in my head.
Anything you want me to try or test just let me know. I have 3 laptops hanging around here and two I know work with qubes, 3rd unknown. And a 4th sitting in the server room at work that’s slow but functional I won’t be deploying anymore.

Anyway,
qvm-sync-appmenus worked it just complained the first time about the VM not running, after I booted the template it ran fine. It populated the menu and apps listed as missing.
A new appVM I created using that template as part of the test which also never appeared on the menu showed up after the template was scanned as well.

Although that led me to the observation that after deleting a Qube it still appears in the menu and doesn’t disappear from Qubes Manager unless you restart Qubes Manager.
I ran a second test using qvm-remove for good measure but same observations.

After restarting the system the two deleted qubes are still on the menu, they must like me.