Kloak won't start and stay up, says condition failed

I tried to install it as a service, but I get this error when trying to download Patrick’s signing key

–2024-01-9 07:17:14-- https://www.whonix.org/patrick.asc
Resolving www.whonix.org (www.whonix.org)…
Connecting to www.whonix.org (www.whonix.org) connected.
HTTP request sent, awaiting response… 404 Not Found
2024-01-9 07:17:14 ERROR 404: Not Found.

I have seen many forum posts discussing how it wont work (unless it is installed in dom0?)
When I add Whonix’s Debian hosts repository and then execute

sudo apt install kloak

I get this :

○ kloak.service - kloak anti keystroke deanonymization tool
Loaded: loaded (/lib/systemd/system/kloak.service; enabled; preset: enabled)
Active: inactive (dead)
Condition: start condition failed
└─ ConditionPathExists=!/run/qubes/this-is-templatevm was not met
Docs: GitHub - vmonaco/kloak: Keystroke-level online anonymization kernel: obfuscates typing behavior at the device level.

Jan 9 016:55:25 installer systemd[1]: kloak.service - kloak anti keystroke deanonymization tool was skipped because of an unmet condition check (ConditionPathExists=!/run/qubes/this-is-templatevm).

I’m not sure if kloak can be installed at all for qubes (either systemwide or just for a template or qube)

If it helps, I created a debian template and tried the install from there in the example above.

Any help would be greatly appreciated, thanks.

I’m not an expert and never used Kloak, but it seems it needs to be installed in a Whonix template, whereas you’re trying to install it elsewhere.