Keyboard and Mouse non-functional after upgrade

I upgraded from 4.x to latest 4.1.2.
All looked like it went well, except mouse and keyboard don’t work at the login screen anymore.

The keyboard works fine at the disk encryption password prompt though.

USB qube is not installed.
Most keyboard+mouse related issues suggest to prevent auto-start of the USB qube.

Anything else I can try?

To be clear - you tried both these steps?

Removing rd.qubes.hide_all_usb did not help?

Thanks for your support.
I tried the first.

There was no rd.qubes.hide_all_usb

Also .../policy/qubes.InputKeyboard has
sys-usb dom0 allow,user=root
as first line ($anyvm $anyvm deny as 2nd)

First, create your sys-usb:

sudo qubesctl state.sls qvm.sys-usb

Then, in /etc/qubes-rpc/policy/qubes.InputKeyboard and /etc/qubes-rpc/policy/qubes.InputMouse, replaces the lines with this one:

 sys-usb dom0 allow

Reboot :slight_smile:

How can I do that without keyboard?

./policy/qubes.InputKeyboard has
sys-usb dom0 allow,user=root.
I haven’t checked qubes.InputMouse, but Keyboard is the essential part anyway.
I followed Locked myself out after creating Sys-USB - #14 by lenis_machines but stopped after 10 because there was nothing to change.
I wasn’t sure about the user=root part, but I left it.

I think this will resolve your trouble :slight_smile:

You’ll be able to use your keyboard.

This skip_autostart doesn’t help. This is why I asked here.
I found these instructions but they have no effect.

did you use skip_autostart or qubes.skip_autostart?
if it doesn’t work, i don’t know what doing. It’s ok for me :confused:

Yes, qubes.skip_autostart
Sorry for the brevity. I’m typing on the phone because I can’t use my computer.
Thanks anyway.

Did you upgrade from Qubes OS 4.0 to Qubes OS 4.1 or just updated dom0 in Qubes OS 4.1?

I followed How to upgrade to Qubes 4.1 | Qubes OS phase 0 to 5

I can only suggest you to boot from some LiveUSB or Qubes OS installer ISO and mount your disk there so you can check the logs in dom0 for errors or related messages.

1 Like

The only log file that meant anything to me was /var/log/boot.log.
It’s all green.
The last entries are:

Starting Qubes VM MyVM1
Starting Qubes VM MyVM2
Starting Qubes VM sys-firewall
Starting Qubes VM sys-net
Starting Qubes VM sys-whonix
Starting Permit User Sessions
Finished Permit User Sessions
Started Command Scheduler
Starting Hold until boot process finished up
Starting Terminate Plymouth Boot Screen

You can check journal files:

sudo journalctl --file /var/log/journal/*/system.journal

Or other journal files there.
Do you have USB keyboard and mouse? Do you see any USB devices info in journal files?

1 Like

I have USB keyboard and mouse.

There are a bunch of entries related to USB. I summarized them below. There were also a few errors that seem unrelated, but I added them anyway:

usbcore: registered new interface driver usb_hid
usb_hid: USB HID core driver

usb usb1: New USB device found, …
usb usb2: New USB device found, …
usb usb3: New USB device found, …
usb usb5: We don’t know the algorithm for LPM for this host, disabling LPM

usb usb8: New USB device found, …

usb 1-3.3: Manufacturer Logitech (my mouse)
usb 1-6: Manufacturer Cherry GmbH (my keyboard)

/usr/lib/systemd/usbguard.service:15 PIDFILE= …

A bunch of the following errors. They seem to be related to Qubes I deleted a while ago:

libvirtd[2473]: unsupported configuration: unknown OS type ‘pvh’
libvirtd[2473]: Failed to load config for domain ‘salt-test-vm’

systemd[1]: udisk2.service: Failed with result ‘exit-code’ (127)
systemd[1]: Failed to start Disk Manager.

kernel: usb 1-3.3: USB disconnect, device number 4

kernel: usb 1-6: USB disconnect

usb 1-6: Manufacturer Cherry GmbH
kernel: input: Cherry GmbH CHERRY Corded Device as device/pci0000:00/,…
kernel: mtb-probe[7941]: checking bus 1, device 10 … usb1/1-6
kernel: mtb-probe[7941]: … was not an MTB device
qrexec-policy-daemon[7993]: flatpack:symbol lookup error: /lib64/ undefined symbol: rpmvercmp

After this last line, the log starts showing the shutdown procedure after I pressed the power button.

Check the Command line: from journal to see that you don’t have rd.qubes.hide_all_usb there.
Is there any related info before USB disconnect message?
What if you disconnect and connect your keyboard USB cable on login prompt? Will it show any USB messages in journal?

Sorry, the “disconnect” was from me removing and re-inserting mouse and keyboard after I discovered it doesn’t work.
I did a clean startup also with qubes.skip_autostart

The only occurence is:
dracut-cmdline: Warning: USB in dom0 is not restricted. Consider rd.qubes.hide_all_usb or usbcore.authorized_default=0

I saw this message popping up before the upgrade for a split-second on startup.

I’m out of ideas for now.
I thought of trying to boot without Xen to rule it out, but it’s unlikely to be the source of this problem:

Thanks a lot for your help!

I guess I’ll try a fresh setup and check if the scheduled backups worked😉
Otherwise I might try to get the VMs using How to mount a Qubes partition from another OS | Qubes OS

Most relevant data is supposed to be committed to hosted Git repos anyway, but some stuff from the last day might be missing.

I bought a PS/2 keyboard, but it behaves the same.
I can enter the disk encryption password, but at the login screen pressing a key has no effect