Kernel panic during installation on AMD 7840HS with 780M iGPU

I am trying to install QubesOS on a Lenovo IdeaPad 5 Pro AMD 7840HS without dedicated GPU. When I try to install the Computer is just rebooting after saying

(XEN) Xen is relinquishing VGA console.

for both Qubes-R4.1.1-x86_64.iso, and Qubes-R4.1.2-x86_64.iso. I tried to select “Install Qubes OS R 4.2 using kernel-latest (6.1.12-1.qubes.fc32)” and edited the xen line by adding loglvl=all. Same.

I have found these links (sorry for the whitespaces as a new user it won’t let me add more than two links in one post):

  • https:// github .com/QubesOS/qubes-issues/issues/7856,
  • https:// forum.qubes-os .org/t/ryzen-7000-serie/14538/20 and
  • https:// forum.qubes-os. org/t/installing-qubes-is-impossible-what-am-i-supposed-to-do/14743

Therefore tried to add x2apic=false to the xen command line and also downloaded the latest ISO from here (which lets me select “Install Qubes OS 4.2.202309231123 using kernel-latest (6.4.13-1.qubes-fc37)”) but without success.

Is there anything that I can try now or should I give up?

Could you try the upcoming new version in its Third release candidate? Download Qubes OS | Qubes OS

It’s not stable yet, but this would tell if a newer than 4.1 Xen and Kernel will allow your system to boot. I guess your computer is too up-to-date compared to Qubes OS 4.1

You mean " Qubes release 4.2.0-rc3"? As additional information I can install and boot Linux Mint 21.1 with Kernel 5.15.0-56-generic without problems (except maybe iGPU acceleration is not used I am not sure window movement and scrolling is not so smooth there).

yes, this one

Yes I will try it. Downloading at the moment. Thank you for this hint.

Same issue with this version. Still reboots.

I’m a bit out of ideas then…

Maybe there would be some option in the bios that would help, but I can’t tell where to look.

I was thinking that maybe there is some more log that I cannot see. Can I pass some parameters to “avoid GPU stuff”? The line (XEN) Xen is reqlinquishing VGA console is not appearing anymore or maybe it appears for a millisecond with this latest version. I cannot tell what that last log line is that is flashing up shortly because then everything gets black immediately after this line appeared and a few seconds later there is a reboot.

I tried many BIOS combinations but without success. Can I somehow save the log output to a USB drive?

I have found out more. I get a kernel panic.

With this settings I can read the error.

It is a kernel panic.

Here people are talking about the same issue:

1 Like

I have written down the call stack:

? die+0x36/0x90
? do_trap+0xda/0x100
? amd_cpuid4+0x18f/0x270
? do_error_trap+0x6a/0x90
? amd_cpuid4+0x18/0x270
? exec_divide_error+0x38/0x50
? amd_cpuid4+0x18f/0x270
? asm_exec_divide_error+0x1a/0x20
? amd_cpuid4+0x18/0x270
? pfx_cacheinfo_cpu_online+0x10/0x10
? __pfx_smpboot_thread_fn+0x10/0x10
? __pfx_kthread+0x10/0x10

It seems it’s a bug in the linux kernel, and still not patched (the patch linked is from early september).

I successfully installed Linux Mint 21.2 and tried to run whonix in virtual box. I also get a similar error there on boot.

Thank you. Can I do something? How long do you think will it take for the patch to make its way into the kernel and finally into QubesOS? I am thinking about returning the laptop. It is very new, says Mfg Date 2023/09/18. I bought it specifically to use QubesOS.

I’m not very up-to-date on Linux kernel development pace, but I think you won’t see that in Qubes OS before a few months from now. First, the patch need to be reviewed and included in Linux code, then Qubes OS should ship latest kernel releases, the patch would make it into linux 6.7 or 6.8 I guess, so yeah, a few months seems realistic.

But it’s curious Linux Mint boots and works! So maybe there is something else, or they added some custom patch to their kernel :thinking:

1 Like

I see the problem seems to occur with AMD Ryzen7 7840HS, 7840U, 7940HS

Here the someone with the same laptop (Ideapad 5 Pro Ryzen7 7840HS) also cannot run virtualbox.

And German:

Also the virtualbox forum is full of this problem:

All of these people did not come as far as we did and still have no clue, I have at least found the mailing list. Someone should tell them on virtualbox forum about this thread. I tried but it Oracle requests too much info like telephone number and postal address which I am not willing to provide just to post in that forum.

Thank you for this info then I guess I will return it. Or can I somehow compile a kernel patch into an ISO of QubesOS. I have some coding and build system experience but never compiled a kernel. How difficult is that? Do you think I just apply the patch to some git repo and adjust some build variables to point to the patched repo directory and create a patched ISO of QubesOS? Is it along these lines or is it more complicated?

But it’s curious Linux Mint boots and works! So maybe there is something else, or they added some custom patch to their kernel :thinking:

Indeed I am also wondering about this but somehow it must have to do with virtualization, not with a custom patch because I can also run a old Ubuntu live system on this laptop.