Kernel-latest-6.3.2-1 not stable

I was on kernel-latest for a months. Kernel 6.2.10-1 was stable.

Tried upgrade to kernel-latest-6.3.2-1 and was no stable at all. Took few hours machine turned off itself without a reason. Went back to 6.2.10-1 with Xen 4.14.5 and its stable again.


Mine won’t boot on 6.3.2-1. It just hangs indefinitely. Had to roll back as well.

I’m seeing something where some of my VMs (ones I use to mount thumbdrives, etc.) will become totally non-responsive. You can’t open an xterm in them; they just sit there. The only real sign of their being up is that they show in qui-domains.

I just looked and my qubes are using 6.3.2-1. I just changed that in global settings, to 6.2.10-1; perhaps that will help.

I’m very new to working with kernels (besides just taking what it gives me). Do I need to rebuild the templates or anything like that? Or will the qube use the proper kernel the next time it starts up?

Do I need to rebuild the templates or anything like that? Or will the qube use the proper kernel the next time it starts up?

Xen will use the proper Qubes core kernel number that we’re referencing. The templates are oblivious to the Xen version.

The individual Qubes will also (by default) use the separate updated Linux kernel that ships with the updated Qubes. However, this can be overridden in the “Advanced” tab in the settings of each individual qube itself.

So there are really two kernels at play: The one for Xen (the hypervisor) and the one that runs contained for each Qube template.

To answer your question directly: Your templates need not be recompiled.

Small extra note. You probably need to select the older Qubes kernel at boot time if you haven’t uninstalled the newer one. Select the alternative kernel when the Qubes splash screen first comes up. You arrow can key/enter your way to it.

OK. Let me clarify; I’m talking about the kernel used by individual vms, not by dom0.

This appears to be settable in the qubes global settings window (default kernel used by qubes) but now you’re telling me I need to change something at boot?

Or were you thinking of dom0?


The 6.3.2-1 cut is associated with an update to dom0 (see ruza’s post on how 6.3.2-1 is associated with an update to Xen / dom0).

Right now I am running 6.2.10-1 for dom0 and 5.10.0-23 for VMs.
When switching to 6.3.2-1 for dom0 the system won’t boot for me.

This deserves it’s own thread.

1 Like

been using xen 4.17.0 and 6.3.2 both on dom0 and vm for about 2 weeks, no problem on my side
also been updating xen to 4.17.1 today, after 2h everything seems fine.

note: qubes 4.2

1 Like

Complete report and system:

System: AMD Ryzen 5 PRO 2500U w/ Radeon Vega Mobile Gfx - Lenovo Thinkpad
Installed: xorg-x11-drv-amdgpu
VM version: 5.10.0-23
My system is closest to HLC: report
Notes: Possible “partial” IOMMU support.

Behavior: Works in 6.2.10-1. Refuses to fully boot in 6.3.2-1 (indefinitely hangs after password prompt)

@Sven - I can put together an HLC submission for my specific hardware versions if you would like. I also have a slightly newer model running a Ryzen 7 PRO (Thinkpad, Lenovo) that I am curious if will have the same issues I’ve been having overall.

1 Like

I’m also having issues with 6.3.2

Just had another freeze followed by a reboot, it’s the 3rd time it happened, I never had any stability issues before updating the kernel to 6.3.2.

on qubes_os 4.1, xen_version 4.14.5 and linux_kernel 6.3.2-1.qubes.fc32.x86_64, most VMs run on 5.15.103-1.fc32 though.

no freezes so far.

can also not confirm (6.3.2-1 and xen 4.15 is fine) here but,

linux-kernel-latest v6.3.2-1-latest (r4.1) · Issue #3725 · QubesOS/updates-status · GitHub - maybe refernece the build issue in qubes-issues repo

only vms hang after sleep… but for them i use a different kernel.

I built and tried to use kernel 6.3.8 on dom0 (Qubes 4.1) and I can confirm I got a reboot after a few minutes. No issues with 6.1.x / 6.2.x kernels.

I’ve become quite picky trying new dom0 kernels, mostly testing during a weekend or so. Most following kernels were running fine.

Those Using The XFS File-System Will Want To Avoid Linux 6.3 For Now

1 Like

It’s an old post, the latest kernel available for Qubes is 6.4.8. Kernel version 6.3 is deprecated now in favor of 6.4 anyway.