KeepassXC - hide window to system tray when minimized


I’d like to use KepassXC’s “Hide window to system tray when minimized” option. KepassXC running in the default Vault Domain and the option is ticked under KeepassXC > Settings > General > User Interface > Show system tray icon: ticked & Hide window to system tray when minimized: ticked. The system tray icon is appearing on the tray, but the KeepassXC’s window does not hide, even if the option is enabled. Could someone help me, how could i make the window hidden?

Thanks any help!

This is a known ‘issue’

The reason is the app running in a VM, and that VM just can’t control the system panel at all, as it is handled by dom0 (or GUI domain).

Similar to the full screen ‘issue’:
Not any app can go full screen it’s own. It needs dom0 support to do this:

1 Like

As a workaround, I using it on a separate virtual screen (workspace)
and if I really want to hide, using the
‘Minimize instead of app exit’

In this case if you close the app, it will be hided from the panel, but remaining in the system tray

(removed “[RESOLVED]” from the title as making a post as the solution already does that)

1 Like

Thanks! It seems as a good practice, working very well! I’m not sure why i haven’t thought about his option earlier.

Yet one thing came into my mind: is this the reason why KeepassXC won’t close its database when the screensaver is on? If yes, is there any good practice to close the database even if the screensaver turned on and there was no chance to close it manually?

A post was merged into an existing topic: KeepassXC Won’t Close Database When Screen Locks

Too keep it to one topic per thread I’ve moved this discussion to KeepassXC Won’t Close Database When Screen Locks. Please continue it there.