Kali Template download issue. "Payload forged!"

When I tried to install the Kali template I get suspicious returns:
[user@dom0 ~]$ rpm -q qubescore-dom0-linux
[user@dom0 ~]$ sudo qubes-dom0-update --enablerepo=qubes-templates-community-testing qubes-template-kali
Redirecting to ‘qvm-template install --enablerepo=qubes-templates-community-testing qubes-template-kali’
Downloading ‘qubes-template-kali-0:4.0.6-202106171816’…
qubes-template-kali-0:4.0.6-202106171816: 4%| | 149M/3.32G [12:16<4:21:35, 202
Error canoncalizing file: Payload forged!
ERROR: [errno 2] No such file or directory: ‘/root/.cache/qvm-template/tmp4xa4_2h_/qubes-template-kali-0:4.0.6-202106171816.rpm.UNTRUSTED’

I tried the
sudo qubes-dom0-update --enablerepo=qubes-templates-community-testing qubes-template-kali
command again and it reached 90% before returning the same as ab0ve.

I retried the initial install command several times and it eventually completed the template download. I was able to fix the subsequent dom0 small pool issue with the command suggested here by fepitre: sudo journalctl --vacuum-time=1d
It cleared up enough space to allow the template to install. It updated via Qubes Update tool without issue.

I was and still am a little concerned about the errors I was getting previously such as, “Payload forged!” and “…rpm.UNTRUSTED” though… I cannot find such errors anywhere in the forum.

R4.1 template downloading is unfriendly and susceptable to unstable network.Try more times?

Most probably this should be running out of space in dom0 as you’ve already been suggested

Please do not duplicate posts.

I am not intending to duplicate posts. I realized the other thread is solved and therefore is not actively monitored. Also, clearly based on the terminal output this has nothing to do with dom0 space.

I am concerned there was a security breach in the process. If someone actually familiar with the errors could explain their meaning I would appreciate.