Jittery video

Video’s are jittery, shake.
Fresh install yesterday of 4.1.2 and updated everything.
What could be the cause?

Did you try to give more CPUs to the qube?

Ok not all videos are shaky, I’m watching something in YouTube that is OK, Tubi movies very shaky, Gab Social shaky. And this page https://nodes.presearch.com/ the animated background is shakey but the words and tabs on lower left of page are stable. Not sure what to make of this.

In settings, advanced VCPUs it was 2 I gave it a 10 no help. I went to 90 and my qube refused to open so I’m back to 10.

You gave no info in order to be helped, but I wouldn’t use Firefox, and if you do you can try to install

pulseaudio pulseaudio-qubes qubes-audio-daemon qubes-core-agent-networking tinyproxy --allowerasing

pulseaudio pulseaudio-qubes qubes-audio-daemon qubes-core-agent-networking tinyproxy --allowerasing
pulseaudio: unrecognized option ‘–allowerasing’
E: [pulseaudio] main.c: Failed to parse command line.

You seem to be right about Firefox, I installed Brave and problem cleared up.

Have you tried installing video codecs in the template? This could be the cause of the lags you’re experiencing on Firefox.

A few things worth noting:

  • @tempmail suggested to install a series of packages, and the preformatted code block was not a command to do so, rather it contained some package names assuming you would know what command was needed to install them
  • that list also included --allowerasing which is not a package name, and honestly, while it likely was the result of a copy-pasting mistake, it should probably give pause unless you know exactly what it does… (I mean “allow erasing”, whatever it is, sounds scary, doesn’t it?)
  • executing commands without understanding what they do is always a risk (I suppose you’ve read that a few times on the forum, and you’re aware of it)

In this case, you executed a nonesense pulseaudio command instead of installing a few packages. The error seems to indicate that the option --allowerasing was nonesense enough to pulseaudio to have failed without causing damage, but that was luck and it could have gone differently.

In general:

Never hesitate asking for clarification about what people recommend you to do! If someone suggests to install some package and you’re not sure how, you are welcome to ask. If someone suggests to install some package and you’re not sure why, you’re also welcome to ask!

In this case, for example, @tempmail didn’t give the reason why they think installing those packages may solve the issue you describe. Maybe they’ve had a similar issue before and they can explain to you why those packages will improve the performance of video on your qube, or maybe they’re taking a guess. Unless the suggestion seems obvious to you in hindsight, if you don’t ask, you don’t know!

TL;DR: It is up to you to decide how much you want to understand about a suggestion before applying it to your system, and to evaluate the risks you’re comfortable with taking, but you’re always welcome to ask follow up questions!

But before that anyone is always suggested to give

Well thanks I’ll keep that in mind. Obviously I don’t know what I am doing.

1 Like

I found a fix!

I too have had this very same problem since i started my qubes journey.

You can install the free codev from the rpmfusion repository

sudo dnf install \ https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm

I havent tried debian but you can find a tutorial here: Install Multimedia Codecs on Linux [2023] - LinuxForDevices