IVPN V2ray can't connect need help

Can someone explain me why i have this message error when i try to use v2ray option from the ivpn app ?

Do you have any net qube associated with this qube?

Thank you for your help !

The qube is associated with mirage-firewall and I tried to install GitHub - v2ray/v2ray-core: A platform for building proxies to bypass network restrictions. in the system but this didn’t work. I don’t know what to do more…

Could it be possible for you you try with a simple qube with sys-firewall as a net qube? That would allow to figure if there is an issue with ivpn or the layers added with mirage-firewall and v2ray

I just tried what u say and it doesn’t work too :confused: maybe the problem is the template itself ? I’m using a minimal template for browsing web perhaps v2ray need a full template ? I will try to install ivpn on a full template and give a feedback

1 Like

Random thought, make sure you have the commands ifconfig and route installed in the VM. They have been deprecated for a long time, replaced by the ip utility, but maybe the IVPN program makes use of them. (this would be a bit weird but it’s worth a try)

Hello thank for your help again, but the VM template is a fedora template and i’m getting this error message “No match for argument ifconfig” “No match argument route” i have the same error for ip command these packages doesn’t exist anymore in the fedora repository i think

Check if the package net-tools is installed, I only gave the binary names because I didn’t know the related packages.

On fedora it’s net-tools for legacy network commands Tree - rpms/net-tools - src.fedoraproject.org

why isn’t net-tools installed by default if it’ necessary to handle the os?

i think ss is default tool on debian to view network
and it wors with my tulip rule
ss -tlpn

as I said before, ifconfig and route are obsolete, replaced by ip and ss as you mentioned.

I was only suggesting that maybe IVPN software was relying on the old command line tools.

I’ve just tried to install IVPN in a full fedora template instead of a minimal-template and things is getting worse. First i create a full fedora template and then i tried to connect in my account and i’m getting this error message
this have no sense… qubes-core-agent-networking and iproute is installed in the full template so why i can’t connect to my account ?? The appvm is linked to mirage-firewall if the minimal template can connect the full template should work too no ? (The minimal template where i’m using ivpn is working perfectly without trouble)

@solene I tried to install net-tools in the minimal template for v2ray and it’s still not working

For more information i’m using the last version of Qubes OS 4.2.0-rc4

I recommend you to get in touch with IVPN contact, I’ve been told they have a nice support.

Hello, i find the problem ! I’ve installed ivpn package and net-tools package for testing in the minimal-template sys-net. Then i connect to my account and i tried the v2ray option and it’s working great !

IVPN obfuscation is working only if the user install the IVPN package in the template of sys net. I think IVPN need to detect the network card in the system for obfuscation…

But i don’t understand if this issue is coming from IVPN or Qubes ? This is a little bit annoying because i prefer to install the vpn package in the minimal-web-template

1 Like