Issues with Qubes OS Installing

Hi there. I’m having an issue and I’m not 100% sure what it is.

Hardware details

For starters, my laptop is a Asus GL552VW. Besides the unknown TPM, it technically meets the hardware compatibility requirements.

I’m using a “onn.” USB 3.0 Flash Drive with 128 GB Capacity, if that matters any.

During my reinstall, I followed the guides as closely as I could. I’ve imported and authenticated the Qubes Master Signing Key and the release signing keys, changed the trust level to “ultimate”, I’ve verified the cryptographic hash values and the detached PGP signatures - everything turned out OK or as expected during this process. The only thing I didn’t do was re-verify installation media after writing. When I was doing the installation guide, I did the Windows ISO to USB option and used the Rufus tool. I previously wiped the flash drive using Rufus from the previous ISO install.

After adjusting the BIOs settings, on bootup, I clicked the “Install Qubes OS 4.2.1 using kernel-latest” option this time. This might be my issue, I’m not sure. Either way, this time I didn’t run into any of the previous issues I was dealing with and it was way quicker.

When I got to the “Installation summary” section, I went to the “Installation Source” tab. I clicked the “Auto-Detected installation media” and the device it picked was “sdb” with the label “LABEL=QUBES-R4-2-1-X86-64”. This is where I’m currently stuck at. When clicking “Verify”, I get the Media Verification popup that says “This media is not good to install from.” I want to manually pick out the ISO file, but I can’t find the USB in the device section. Or if I do, I can’t recognize it. I have /dev/sda1, /dev/sda3, /dev/sda4, and /dev/sda5.

I’m not sure if I should move ahead with this (despite it saying it’s not a good media to install from) or not. Any help is appreciated. Thank you!

You can skip verification:

Note: Using Rufus to create the installation medium means that you won’t be able to choose the “Test this media and install Qubes OS” option mentioned in the example below. Instead, choose the “Install Qubes OS” option.

1 Like