Issues Testing Installing Whonix 16 in Qubes 4.1 (beta)

this is what install page says

Ambox warning pn.svg.png Before executing the call in this section, note it can take a long time to finish. Fast Internet connections take only a few minutes, while slow connections can take twenty minutes or more (it is far slower over Tor). No progress indicator is shown, so do not interrupt the salt process once it has started or this can lead to an unstable system [archive]. [6]

However the link to “unstable system” goes nowhere, probably it should not cause a system to freeze, else it should say so IMO

any reason I can’t just install templates the way other templates are installed?

*note 4.0 has not qvm-template-gui

You mean something like this?
sudo qubes-dom0-update --enablerepo=qubes-templates-itl-testing qubes-template-whonix-ws-16

Did you rename any templates? I don’t remember what the installation log showed but maybe the script couldn’t find you whonix templates if they were renamed.

yes, the standard method

$ sudo qubes-dom0-update qubes-template-fedora-XX

is -16 testing? I thought it was “released”, though adw says rolling release above as I recall .

I’ve created a dummy template and uninstalled -15 ; but still have the /whonix.jinja ; which still says ‘16’ ;

I can try again overnight, though if it hangs my system, don’t really want that to run unattended, etc

hey @deeplow , can you split this topic for it to be easier to find?

Actually I think it moved to the community templates, no longer testing. Also if you delete 15, you won’t have whonix connectivity. Shouldn’t you delete it after a successful upgrade?

In case anyone missed it:

However, Qubes 4.1 is still in testing, so Whonix 16 may not work on Qubes 4.1 yet.

I check my… /srv/formulas/base/virtual-machines-formula/qvm/whonix.jinja
and it is already at 16

OK 'WTF"…I followed what they have on whonix site for fresh install

sudo qubes-dom0-update qubes-template-whonix-gw-16 qubes-template-whonix-ws-16
and ni terminal i get
No match for augment qubes-template-whonix-gw-16
No match for augment qubes-template-whonix-ws-16

open dom0 terminal run qvm-template-gui…This is not found in 4.0.x
So I gues my question is are you guys just winging it or what??

same here

@Johnboy yep, I tried it again,samething. I also did the
sudo qubes-dom0-update just to check out and got…No new updates available.

So I am a little confused now as to what is going on here

They’re in the community testing repo:

sudo qubes-dom0-update --enablerepo=qubes-templates-community-testing qubes-template-whonix-ws-16


@airelemental thank you. Are these still in “test” or are they production now???

So then i would do these steps…

sudo qubes-dom0-update --enablerepo=qubes-templates-community-testing qubes-template-whonix-gw-16

sudo qubes-dom0-update --enablerepo=qubes-templates-community-testing qubes-template-whonix-ws-16


sudo qubesctl state.sls qvm.anon-whonix

And this that last cmd will

Configure sys-whonix and anon-whonix safely

Am I correct, if not please inform me.
Again thank you

i’m not sure, it say it “announced”

Post 3 above states it’s done in stages. It currently appears to be in the community testing repo.

that post is outdated

I believe it’s in production now for Qubes 4.0.x and test still for 4.1.

Also say I install whonix-gw-16 & whonix-ws-16.
It states to run cmd…

sudo qubesctl state.sls qvm.anon-whonix

This Configures sys-whonix and anon-whonix safely.

Ok, but do i run this cmd after i uninstall whonix-gw-15 & whonix-ws-15 and that cmd will apply then to 16 gw & ws. Cause if I run that cmd with 15 still installed and operation I think it will not work on 16

it actually reversed

Ok let me get this straight. Whonix 15 is EOL in one month but yet Whonix 16 is still in test for bor 4.0 & 4.1

it released for qubes 4.1 but not 4.0
have you understand it? @B_ryr

Whoops. I might have overdone the post splitting. Not sure if this is what you meant but it’s now done.

yea, you over splitting now, i want it start from post 8 in this topic