Issues getting into bios

hello, I’m a noob in qubesos
I am having problems accessing into the bios of my computer after installing qubesos
before I had windows10
I suspect the the problem lies within the secure or fast boot ?
when I reboot my computer I hear 3 short beeps from the computer.
help wil be much appreciated
thank you!

So you have 3 short beeps when you start your PC and then what? It boots normally or it doesn’t boot and stay with black screen?
You can search for BIOS beep codes decoding for your BIOS for example here:

Thank you for the quick respond
The system boots normally, however I think the problem lies with the keyboard.
Because when I have just booted the pc now
I couldn’t move with my keyboard when the screen of qubes starting options has been shown

I don’t know how Qubes install could have caused your keyboard to stop working at BIOS.
Try to enter BIOS at boot - when you press the power button to start your PC press F2 or Delete key fast and multiple times before you get to the Qubes starting options.

I’ve tried that several times before I posted here …
that’s why I’m clueless…
Even if I wanted to reinstall windows just to disable the fast/secure boot I can’t …

You can disconnect the hard drive with Qubes to see if you’ll enter BIOS because there is no bootable device or not.
Also if you have PS/2 port and keyboard you can try them out.

I’ve tried this today and still the same result…
Unfortunately, I don’t have PS/2 port…

Then you can try to reset BIOS.

After resetting the bios
I still can’t get to the bios or even choose from qubes’s grub list…
But now instead of 3 beeps when booting I have 5 …

sorry for the delayed respond it took me a while to understand how to reset my bios…

What BIOS do you have?
Or what’s your motherboard?
You need to know it to decode beeps meaning.

mother board:
Gigabyte GA-Z270p-d3 1151 DDR4 Z270

Seems to be AMI BIOS:


1 beep – Refresh failure.- (DRAM-Memory Error)
2 beeps – Parity error. - (Memory parity check error-circuit failure)
3 beeps – Base 64 K memory failure. - (Basic memory 64K address check error)
4 beeps – Timer not operational. - (Real Time Clock=System timer failure)
5 beeps – Processor error.
6 beeps – 8042 – Keyboard controller gate A20 failure.
7 beeps – Processor exception interrupt error. - (Virtual mode exception error)
8 beeps – Display (Graphic card) memory read/write test failure.
9 beeps – ROM checksum error.
10 beeps – CMOS shutdown register read/write error.
11 beeps – CPU Cache memory bad. - (malfunction-error - The L2 cache is faulty)

So 5 beeps means that you have a problem with your CPU.
Maybe you pulled it out from socket and insert it back in a wrong way.
Or some metal piece shorting something on motherboard.
Or motherboard/CPU is dead.

I don’t know what happened but I did a reset once again and I Could get into the bios
disabled fast boot and chose the legacy options
and now I have no beeps…

I really don’t know what happened
I really appreciate you help!
thank you!