Issues enabling Flathub in salt config

Hi all,

I am trying to write a salt config to install flatpak in a fedora template and add a remote to flathub.

Flatpak installs just fine however adding the flathub remote is proving troublesome.

Please note, when I set this up manually it works fine.

export https_proxy=

flatpak remote-add --if-not-exists flathub

The issue is that I cannot seem to set the https_proxy var in the salt config to be able to add the remote:

# this part works
    - pkgs:
      - flatpak

# this doesnt 
  cmd. run:
    - name: flatpak remote-add --if-not-exists flathub
    - env:
      - https_proxy:
# I also tried something like this - didnt work 
  cmd. run:
    - name: export https_proxy: && flatpak remote-add --if-not-exists flathub


Also, once the flathub remote has been added to a template I am able to search for flatpaks via command line. However I am unable to install flatpaks, I get a ‘error searching for remote’.

I have seen some posts recommending use of flatpaks in AppVM’s with the --user flag. However is there are way / what are best practices for using flatpaks in templates?