Issue with startup from USB

Hi guys, I’ve been attempting to run Qubes from a USB on my MacBook Pro 2017. It managed to install perfectly from the installer on a secondary USB and everything was all in the clear, however when I attempt to run it from disk selection I’m presented a spool of text which ends with:

Panic on CPU 0:
FATAL TRAP: vector = 6 (invalid opcode)

Reboot in five seconds …

I’ve looked quite heavily online for a solution but it seems no one else has had this problem with Qubes, I do have a few ideas following research however:

  1. I did find a similar error someone experienced with a Linux system that seemed to be solved by disabling “secure boot”. I attempted to turn this off in the disk utility but it seems the option to do so isn’t available in later Macs. I tried disabling system integrity in the console but that led to a different error. Is it possible to disable secure boot on this Mac and if so would it help?
  2. Are later Macs simply incompatible with the OS? Has anyone else been able to achieve this setup on a later Mac (running Qubes from a USB). If so please comment.
  3. The USB I’m using, a Kingston Data Traveller 100 G3, is known to also be incompatible with booting other operating systems on, for instance Tails as listed on the Tails website. Is this USB known to be incompatible with bootable OSs in general, if so is there anyway to format it such that it isn’t?

If you have any information on any of these possibilities, please comment. I’m hoping that by process of elimination I’ll be able to determine what the issue is before I go out and buy a different computer/USB haha

I have it installed on a SanDisk Cruzer Blade USB and it boots fine, but I have come across that problem before where some machines don’t seem to recognize the USB.