Issue with dm-crypt in qubes-4.2.0 installer

Hi, Greeting

So, I was clean installing Qube stable ver 4.2.0, and it present me error about FAILED to access PASSPHRASE or invalid passphrase.

step to reproduce on my end:
plug the dd format bootdrive
select " test media … "or “start qubes installer”
after that on disk select option select “Auto” partion then begin install,
the error come on luks open step

Things I tried:
Verify the ISO file again, check hash value again, rewrite with dd then verify again : didn’t work same problem
download the Iso file again then process with prev steps, it didn’t work either,
search in duck about failed passphrase, where its said bcz of prev luks header or something, so I spin up a live fedora then dd it with urandom & zeros but again it didn’t work.
sometime later tried again with qubes iso to find the main problem, on tty where I use cryptsetup luksFormat encrypt work but luks/Open failed " no passphrase available". tried in tmpfs same case, but luks1 work in both. Also fedora 38/39, debian12 iso, memtest & smartctl work without any problem.

so, Is there any solution this problem, plz help !!!
Also if any details needs, willing to share.


Did you try with a “simple” password? - with only ‘latin1’ letters? - just to rule out an issue with encoding of letters?

in tty & gui, for testing tried 1234567890 also other simple passes, nothing works in luks2 however in luks1 its works with any complain

What’s your hardware?
Maybe not enough RAM?

Type: Desktop Mobo: Micro-Star model: A320M-A PRO (MS-7C51) v: 1.0
Info: quad core model: AMD Ryzen 3 3200G with Radeon Vega Graphics bits: 64
ID-1: /dev/sda vendor: Hikvision model: HS-SSD-C100 120G size: 111.79 GiB
Ram : 32GB

Add --debug to cryptsetup open when you try to open luks2 and check the output, maybe there will be some specific errors.

Also test your memory, maybe it’s faulty.

Here the log on cryptsetup
cryptsetup.log (8.7 KB)

memtest86+ report no error

Nothing interesting in the log.
Try to create container in RAM to exclude the problem with your SSD:

# tmpfs so no physical storage is involved
mkdir /mnt/tmpfs
mount none -t tmpfs /mnt/tmpfs
cd /mnt/tmpfs

# luks container file
truncate -s 100M foobar.img
cryptsetup luksFormat foobar.img
cryptsetup luksOpen foobar.img foobar

not worked, same problem, already tried that, however it work with fedora live.
also truncate avail in qubes iso, used dd, is that a problem?

not available*

Maybe try to boot the Qubes OS installer with kernel latest. Maybe there is some problem with the kernel.
You can also try to boot from Qubes OS 4.1.2 installer and check cryptsetup there for a test.

No, it wouldn’t matter.

alright, will update tomorrow, night

not work

worked without any problem

I’d try out Qubes OS 4.2 rc’s starting with rc1 and then report this issue as regression on github.

alright, as luks1 working, I will install qubes with luks1 FDE then will upgrade to luk2 to see if i can get hunt down this problem, if i found somthing will report it later

anyway thanks @apparatus for you valuable support and also others in this thread.


@apparatus It finally work after i swap ram slot & clear CMOS, create boot drive again to another flash drive. it magically fix it, don’t know what the cause is.

anyway, sorry for all the trouble i cause you, and Thank you very much.

BTW memtest still show no error found