ISO running latest kernel

I’m using a fairly new computer, and it seems to work only with newest version of the kernel (fedora 39 with kernel 6.5.11 works oob).

So, I’m trying several things to hopefully get QubesR4.2-rc4 to work on new hardware :

  • installing QubesR4.2-rc4 on a computer, and update dom0 to fedora 39 / latest kernel, so far I didn’t manage this, I’m going to try again later
  • I looked into building my owns ISOs but it seems the documentation isn’t up to date (I’m guessing the update to the build system of R4.2 might have something to do with it)

Did anyone managed to run Qubes on newer hardware ?
What’s the estimated release of a new ISO running fedora 39 or latest kernel ?

If you have specific information on how to make a functional ISO with compatibility with newer hardware I’ll be glad to know !
And if there’s anything I can do to help with hardware compatibility LMK.

1 Like

What’s your hardware?

Not any time soon, maybe for Qubes OS 4.3.

You can try weekly build:

1 Like

Can you share the specs from your new computer?
dom0 versions are kind of static, it’s running Fedora 37 right now and I don’t think it will change anytime soon. If you installed Qubes 4.2, what are the issues?

Hi !
I’m running an AMD Ryzen 5 7040.

Install usb-stick and previously installed qubesOS will not be detect as bootable device by the computer.

You can try weekly build:

How can I see the weekly build spec ?

Don’t know about specific image spec, but the latest image will have the latest package versions that were on the date of weekly release.
You can check the package updates here:

Or you can check the Qubes OS current-testing repository for package versions and their release date to know which packages could be in the ISO:

Tried latest weekly build and device isn’t bootable.

I’ll try installing latest kernel in dom0 and transfering the disk to my computer… (also latest xen available).

I tried to build newer kernel but failed to.

I’ll take a deeper look into building kernel for Qubes and try to build kernel 6.5+ to hopefully get things working with newer hardware.

LMK if you have up-to-date guide and tips to avoid common pitfall :slight_smile:

Can you detail your building process and where it failed?

Hi, sorry for late reply.

I followed this :
As it was mentionned on this forum, I think I may have stumbled upon an older guide…

Failed at the first step (make rpms).

I checked the branches on the git, and there isn’t a branch for kernel 6.5+, so I may have to wait or try to works this through and ask for a merge request later.

This guide is very old.
To build the kernel version you want, you need to use the qubes-builder:

Seems that I can finally boot the live ISO since R4.2.

Now I’m having trouble with some other things, going to open a new topic.

Thank you very much for your help ! :smiley: