Is there a way to cancel this backup?

I have completed many backups successfully. Yesterday, I started a backup and it hung at 3% for a while. I clicked on Cancel on that screen. However, it did not change. Then I clicked the X and the window closed.

Now 12 hours has passed, but if I go to start a new backup, it says there is already one is progress. Is there a way I can kill the backup process manually?

I know a reboot might work, but I hope to get a successful backup before rebooting, just in case it cannot start up everything properly.

Try this:

sudo killall qubes-backup-restore

in dom0.

I get “qubes-backup-restore: no process found”. I am in dom0.

Then I tried again to start a backup, but it (again) says already in progress.

Try this:
sudo killall qubes-backup

qubes-backup: no process found

There seems to be a process running called writeback. Should I kill writeback?

qubes-backup: no process found

There seems to be a process running called writeback. Should I kill writeback? Is that safe?

Is it safe to reboot?

I was in a similar situation a few days ago, and got it to go away by doing a ps -flea | grep -i backup and very carefully picking the process number to do a sudo kill -9 on. (You will also see your grep command listed, so please don’t go indiscriminately killing everything listed.)

However, don’t do this immediately…I am a wet-behind-the-ears n00b and there might well be a good reason NOT to do what I did. Let’s see what @tzwcfq has to say.

2 Likes

Thanks! I see the qubes.Backup process.

Was your backup hanging? Do you know anything about reasons why it would hang? (I’m backing up to the same drive that worked before, in the same way, and it has plenty of disk space.)

Mine wasn’t hanging, but I realized I had asked it to back up a ton of stuff that wasn’t worth while. It probably would have taken several hours to complete and I decided to cancel it. I was planning to do a more urgent backup after the one I canceled, and couldn’t, because there was allegedly a backup in progress.

Hitting cancel, though, left me with a window that might as well have been hung; it didn’t do what one would expect (close up and go away, having canceled the backup). I don’t know what the expected behavior is, but to me it looks like it may even have hung in the process of canceling. A cancel that doesn’t cancel pretty quickly might be a bug.

Yeah, same. My original backup process has still been running 18 hours later, but I killed the process like you said. Thank you again.

Now I started a new backup, a much smaller one, but I’m worried it might be hanging again already.

They do go more slowly than you’d like, and rather intermittently. It will hang at some percentage for a long time, then race ahead (comparatively speaking).

I suspect that it’s having to slow down to work hard at compressing some bits but not others, but that’s pure speculation on my part. (Coming up with a useful progress bar can be a complicated thing. If it is an eight step process, for instance, with one part that’s longer than the others (and can’t be predicted), how do you show it? 12 percent, 25 percent, 37 percent? Or do you try to guesstimate how long that variable part will take?)

Yeah, I’ve noticed that too, although I have not used compression for backups. Thanks for discussing this.

I’ve got 80 GB of space, without compression I’d have room for one backup of all of the VMs and templates.

1 Like