Is Macbookpro 2020 (intel) supported? IMG IN

Hi everyone,
I got a problem when start to install qubes os via usb into macbookpro 2020. You can see error at the below img. I did not find any solution or any tuto for mac. I got limited knowladge about OS or low level programming. Do u know how can I fix it or should I buy qubes os friendly laptop?

I want to really use too much Qubes Os. I am working on than 2 days to install it :slight_smile:

1 Like

Hi, and welcome to the forum!

I think @alzer89 would be the best to ask. Apple stuff seems not too cooperative unfortunately, but he has made them do what he wants to and run qubes.

1 Like

Hi @kolpa1324ff,

Basically, my gut tells me it looks like you might need mapbs=1 noexitboot=1 in your xenopts (I’ll explain what that means, don’t worry).

It looks like Apple’s EFI bootloader is doing things that a bootloader doesn’t need to (and shouldn’t) do…. Typical Apple……

Do you know the model number of your MacBook?

That would allow me to give you a better direction as to how to get Qubes OS running.


Thank for fast replies @Suspicious_Actions and @alzer89.

model number is A2251
I am waiting for explains :slight_smile:

Thank you.

1 Like

Oh god….it has a TouchBar……

Do you have an external USB keyboard handy? You’ll need access to the function keys…


Also, can you provide me with more information about what you were doing when the screen showed this?

Were you booting from the installer ISO, or were you able to successfully install it, and was this after a reboot?

Hmmmm… I got type-c external keyboard. Is it ok?

Yes it was after reboot. I writed ISO into USB stick. When creating bootable usb I tried two different method. balenaEtcher and
“sudo dd if=Qubes-RX-x86_64.iso of=/dev/sdY bs=1048576 && sync”. but result same.

I gonna explain step by step:

  • rebooting mac and holding [option] button when apple logo shown,
  • I see macintosh or EFI boot (qubes os) screen.
  • I select EFI and shown Qubes install menu. (if u want I can send ss) (Install qubes os, test media and install qubes os etc…)
  • After selecting Install Qubes or test media and install, screen freezes 10sec and prints that logs at the attached ss
  • When error log shown, I can’t use any control on mac (keyboard or mouse) It freezes.

If it has function keys (F1 F2 F3 etc.), then yes.


Ok, so that’s from the Qubes OS installer ISO.

You’ll probably need to add some extra kernelopts to GRUB.

I’ll explain how to do that:

  1. When you see the GRUB menu, immediately highlight “Test this media and install Qubes OS”
  2. Press “E” to edit the config file
  3. Add mapbs=1 noexitboot=1 to the kernelopts.
  4. Press Ctrl + X or to boot

This should explain things a bit better:


Added params into config file:

And than pressed f10

Result is same :frowning: :
Btw thank you @alzer89 and sorry to wasting ur time.

You put it on the initramfs line.

Put it in the line with “vmlinuz” on it, and try that.

If that doesn’t work, put it on the “multiboot2” line.

1 Like

None of them don’t work :frowning:
Why os installer does not prints any log about error?

A post was split to a new topic: Can I run qubes os clearly on Lenovo Thinkpad E15 Gen2 Intel Core i7 1165G7?

You can try to install Qubes with the latest Qubes 4.1 ISO build with kernel-latest:
I had a different problem with installation and kernel 5.10 didn’t work for my hardware but kernel 5.17 (kernel-latest) worked for me.


@tzwcfq same error :frowning:

Thanks for ur interest