Internet speed issues with DL speed - UL OK

I use Qube’s OS 4.1.1. I only get a relatively slow connection to the Internet. I should be able to reach at least 100 Mbps. However, I get a maximum of 20 Mbps download via WLAN and a cable connection. There are no problems with the upload. I tested it using various speed tests on the Internet. What could be the problem?

Thanks for your help.

I have the same problem. My upload is advertised by ISP but my download is 3.5 times slower than advertised, even significantly slower than upload.
On my phone and other Windows laptop, no such issues, so it looks like Qubes specific.

I have even tried dispVM Firefox connected directly to sys-net, and tested it on speedtest. Same as above.

Did you test the speed inside sys-net?

No, dispVm directly attached to sys-net?

I would try to run it directly in (disposable) sys-net.

In sys-net it is as declared, almost (but it counts as “up to…”)
Out of sys-net experimented with various RAM amount in various qubes, including sys-xxx’s, but it looks it doesn’t matter. The best I achieved was DL=nominal UL

What is strange is that UL is always max/nominal.

I have changed the topic subject to better reflect the issue.

(Tried in terminal with curl -s | python -, it’s OK, and with bittorrent - same issue).

Firefox used with only HTTPS Everywhere. CPU related?

If CPU is the issue you could probably check it with xentop in dom0 console, or with the GUI icon.

Thanks. I already didn’t see any CPU throttling/issue, just blindly guessed what it could be else…