Internet connection is nearly unusable on wifi, but solid on ethernet

I have had this going on for quite some time, but I haven’t gotten around to asking about it until now.

I am running on a Framework 13 AMD version, and I am currently using the Intel AX210 card (which I used previously with great success on the old Intel 11th Gen mainboard before upgrading to the AMD Mainboard). So I assume the card is fine. Plus I generally have been working off of a Fedora 39 Live Session for the past couple months since this issue began, and I have never had any issue on Baremetal Fedora.

The Symptoms are simply a connection that barely works and seems to come in and out BUT the actual “wifi connection” never drops. Meaning I am connected constantly, but the connection just doesn’t transfer data very well. Ethernet connection to the same router works just fine. And connecting via wifi on my baremetal Fedora Session on the same laptop also is perfectly fine.

I have tried to check the journalctl logs on sys-net and sys-firewall, but there does not appear to be anything that might be indicative of an unusual issue there. Is there some other log I could check that might elucidate this issue? I don’t know much about how to diagnose this beyond those logs, but if anyone is willing to take some minutes to help, I am happy to look into anything that you might suggest!


1 Like

are you connected to a 5 GHz network that is behind a wall? Did you move the laptop or wifi access point since you tried fedora 39?

You could check dom0 journalctl to see if it has hardware errors.

1 Like

Thanks for taking a minute to look at this (and for all the other things I see you doing around the community!).

As for the things you asked: I am using 5GHz, but I am right next to the router, and Fedora baremetal has no issue here (or even further for that matter). The laptop is in the same position.

I did check the dom0 journalctl as you suggested, but the only error so far is just a PAM error from the Qubes Screensaver lock (which I think is always there).The sys-net journalctl report sometimes shows one thing that looks maybe network related??

Apr 18 21:34:30 sys-net systemd[1]: Started systemd-hostnamed.service - Hostname Service.
Apr 18 21:34:30 sys-net kernel: audit: type=1130 audit(1713490470.778:458): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init>
Apr 18 21:34:30 sys-net systemctl[45113]: Failed to connect to bus: No medium found

But I don’t know if it is related or what it means.
Is there any other log I should be looking at?

1 Like