Internet connection failed

Hello folks, i am facing a new problem today. I have tried to connect to the internet through whonix, firefox but from different qubevms but neither working. On firefox the page doesn’t load up and on tor i get connection failed. As i figured out my qubes can’t connect to the internet and on sys-net settings it don’t display the network icon.
P.S i am using ethernet cable to connect to the internet.

Do you mean there is no NetworkManager icon in dom0 tray for sys-net?


What’s the template of sys-net?


Minimal or normal one?

Sorry for late reply. the normal one, net qube is set to sys-net.

How did you create sys-net? Was it created by default during Qubes OS installation? Did you make any changes in sys-net or sys-net template?

I’v tried to install mulladvpn and create a new qube, but the installation failed cause i had no internet connection

I’v chose to provide internet through mullad in all qubes. Do you think this is the reason i have no connection?

Do you have internet in sys-net?
Try to ping from sys-net terminal:


If you’ve created mullvad VPN qube and set it as netvm for all your qubes then you won’t have internet in your qubes if your mullvad VPN qube is not providing the internet correctly. Maybe your mullvad VPN qube is misconfigured.

It seems that i have internet connection, maybe i misconfigured vpn i will delete and do it again.