Internal microphone not receiving input but attached

So, as in the Subject.

I can attach microphone to dispVM (via device widget - dom0:mic) without errors, but no input is heard in the VM. I can hear the playback.

If it’s related: I have (playback) working sys-audio, and in Input Devices of it’s pavucontrol it shows “Microphone (unplugged)”

I am actually totally unaware where the microphone should be recognized. This is the first time I ever deal with (internal for now) microphone under Qubes. I read a lot of resources, but am not clear where to start from when having sys-audio.

Should I attach it to sys-audio and then all VMs whose audiovm is set to sys-audio should work, or I shouldn’t but to attach it to each VM per session, or how?

Please help.

First bump.

Can someone at least describe what expected behavior is about internal microphone when having sys-audio, please?

I am not sure about that at all. But I suspect that would be enough for me to diagnose it and resolve it.

I cannot provide details about the sys-audio as I have yet to experiment with it.

As for the issue you’re facing or the input issues I’ve faced in general, in dom0’s or sys-audio’s pavucontrol (whichever manages your audio controller), verify that:

  1. Your audio controller has a profile that supports input under “Configuration”;
  2. Under “Input Devices”, the microphone is not set as muted;
  3. Under “Recording” tab, the VM’s “record from” is not set to a monitor of your audio controller
    This is the likely culprit in your case. Assign the controller itself here.

Thanks for your response @observinglynx.

  1. It has. I have to choose “Analog Stereo Duplex” in order microphone to be shown in Input devices
  2. It’s not. Qubes Vchan is set.
  3. Under “Input Devices”, the microphone is not set as muted, but it shows “Microphone (unplugged)”. If I try to attach it from dom0 to sys-audio, it obviously refuses it, because sys-audio has to be set to has no audiovm.

I have no idea where microphone should be present. In dom0 or sys-audio, do I attach it to VM or first to sys-audio. I’m totally confused.

Could you provide the link to the guide that you used to set up sys-audio and is your audio controller attached to sys-audio or dom0?

I used this guide when first created sys-audio with f37:

combining with my approach of using minimal templates after creating sys-audio and comparing with other resources here. After that, with f38 and f39, I use simple export list of packages from such created f37-minimal sys-audio template, and install that list into newer fedora-minimal version. After that create new sys-audio based on it with autostart pulseaudio .desktop files in it from the guide above, delete the old one, and no problem.
It always worked out of the box when playback was. I never needed to use microphone until now, though. I have Headphone/microphone combo port and web camera with integrated microphone. I need the latter one to work, obviously. Web camera works when attached to VM: video and playback, but the other part can’t hear me, because no microphone is detected in sys-audio’s pavucontrol.

But, ran into new issues while wildly experimenting. Now I have f39 sys-audio, and it doesn’t receive any stream from outside. Tried with f38 backup, with xfce, nope. At least with f38 I didn’t change anything, so it should work, but no. Which makes me think it’s now something with dom0, and I didn’t do there anything except changing audiovm prefs of other VMs while trying… Even tried to recreate sys-audio from scratch following the guide above. Nope. So, now nothing works except sound in sys-audio itself.

But please if you have any ideas regarding microphone meanwhile, post it here.

EDIT: playback resolved. Somehow, now I needed this line 50-sys-audio.policy, although can’t remember why would I touch the policy, let alone the line at all

admin.vm.feature.CheckWithTemplate +audio-model sys-audio @tag:audiovm-sys-audio allow target=dom0


Out of the blue, totally new property might prevent you from hearing sound from sys-audio. Just discovered it when starting some VM. +stubdom_xid sys-audio @tag:audiovm-sys-audio allow target=dom0