Intel_pstate=enable doesn't work in qubes?

added intel_pstate=enable to boot option but intel_pstate is still off and xenpm is still using acpi driver. Is the intel_pstate=enable boot option removed from qubes?

Which version of Qubes OS are you using?

Qubes release 4.1.2

You should try Qubes OS 4.2 which was released a few days ago. Hardware support is greatly enhanced.

intel_pstate won’t work in dom0:

You can enable the HWP support in Xen instead. It’s enabled by default in Qubes OS 4.2, for Qubes OS 4.1 you can add cpufreq=xen:hwp Xen command line option in GRUB.

I tried HWP but it is worse than the acpi driver for me. Why intel_pstate won’t work?

Read the comment in my link.