Intel NUC11PAKi5

Remarks

Product specifications: Intel NUC11PAKi5.

  1. Secure Boot needs to be disabled: F2 then Setup > Boot > Secure Boot.
  2. Only UEFI is available. Legacy BIOS is not available in NUC11. (Intel docs)

Qubes OS releases

Installation media: USB thumbdrive.

  • R4.0.4: the machine rebooted before the installer became visible.
  • R4.1-alpha20201014: the machine rebooted before the installer became visible.
  • R4.1-beta1: installation OK. Performed a default installation (with Whonix).

Testing R4.1-beta1

  • Display at native resolution (2650x1440) OK

  • Wired network OK

  • Sound via HDMI seems OK (but the screen doesn’t have any speakers :woman_shrugging:)

  • Sound via headphones in front JACK not OK, no output device is available. (That works fine with Tails 4.19.)

  • WiFi seems OK (but I haven’t actually established a connection)

  • USB keyboard and mouse OK (Note: no sys-usb was created by the installer, I didn’t add done either at this point.)

  • Bluetooth, I can’t find it, not OK

  • IR receiver, I can’t find it either, not OK

  • Microphone OK

Attachments

None yet. I’m still testing and will edit this post when ready. In the meantime, if you have questions, I’ll do my best to answer :slightly_smiling_face:

2 Likes

As it is a Realteck Audio Chip sound may work with this …
sudo echo “options snd-intel-dspcfg dsp_driver=1” > /etc/modprobe.d/alsa.conf

Do you have visual glitches, specially at LUKS password input and/or mouse pointer?

I guess suspend doesnt work?