Intel Corporation Killer Wi-Fi 6 AX1650i is not killing it

I cannot use my impressively named wifi adapter. Following some great tips from @ludovic I have identified the device and migrated the underlying TemplateVM to Fedora 32 because it has a kernel that supports the device. I now get the following:

[user@sys-net ~]$ lspci | grep Network
00:07.0 Network controller: Intel Corporation Killer Wi-Fi 6 AX1650i 160MHz Wireless Network Adapter (201NGW) (rev 30)
[user@sys-net ~]$ lspci -s "00:07.0" -v -n
00:07.0 0280: 8086:34f0 (rev 30)
	Subsystem: 8086:0074
	Physical Slot: 7
	Flags: bus master, fast devsel, latency 0, IRQ 5
	Memory at f2010000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
lspci: Unable to load libkmod resources: error -12

The issue persists after a complete reboot.

Without knowing the kernel module, I’m not sure how to proceed. Is there an additional package I need to install?

(Beyond this, I can create a wifi connection in the sys-net Network Connection tool, but it doesn’t show up in the applet dropdown. I assume this is because the device is not recognized.)

Hi @lofidevops,

From your identified the device link, switch to the page (#5) which talks about your laptop (Lenovo ThinkBook 15 IIL), follow an example (Ubuntu 20.4) and you will get the used kernel module.

Then you’ll check your sys-net kernel version (note that by default it’s the same as dom0, not the Fedora 32 templateVM kernel).
Search, and you’ll identify the minimal kernel version.
In the Qubes OS documentation, you’ll see how to install a more recent kernel (advice: before, do a backup), and how to configure the kernel for an AppVM from Qubes Tools.

Maybe (or not) a firmware package is also useful.

I hope this will help you.

1 Like

Attempted updating dom0 kernel to kernel-latest. Graphical glitches on disk password screen, black screen and pointer on start. Now reinstalling QubesOS :grinning_face_with_smiling_eyes:

If you are using legacy boot, it is very easy to select another kernel from a grub menu after a reboot.

What I’ve tried so far:

  • Installed kernel-latest-qubes-vm
  • Switched sys-net kernel to 5.9.14-1 (should support device according to Linux Hardware link)
  • Rebooted physical machine, no improvement
  • Re-ran the lspci commands above, confirmed the kernel driver/module is iwlwifi
  • Tried the following in sys-net terminal (hints from suspend/resume troubleshooting with no improvement:
$ sudo rmmod iwlmvm
$ sudo rmmod iwlwifi
$ sudo modprobe iwlwifi
$ sudo modprobe iwlmvm

The wifi option does now appear in the network applet. I have defined a valid wifi network via applet settings (right-click menu). Under “Wi-Fi Networks” the message “device not managed” appears. When I click to reveal the applet dropdown, the “Wi-Fi Networks” section appears and disappears.

Because I reinstalled the OS, this is all using the Fedora 30 TemplateVM. I’ll try with Fedora 32 next.

Hmmm, I have the same symptoms after switching the sys-net TemplateVM from Fedora 30 to 32.

What I noticed this time round is that on system startup the network applet:

  • Does not show “Wi-Fi Networks”
  • Does not have the option “Enable wi-fi networks”
  • Lists “Ethernet network” (with “Wired Connection 1”) and “Ethernet W0.7”

If I stop and start sys-net then:

  • “Ethernet W0.7” no longer appears
  • “Wi-Fi Networks” appears (with “device not managed”)
  • The option “Enable wi-fi networks” is present and enabled
  • Lists “Ethernet network” with “Wired Connection 1” as normal

If I restart sys-net then:

  • Neither “Ethernet W0.7” nor “Wi-Fi Networks” appear
  • Lists “Ethernet network” with “Wired Connection 1” as normal

If I physically disconnect the ethernet connection at any stage, including before a system start, that option does not appear and the symptoms for the wifi connection are the same.

Is there any further info I can provide? Now that I’m using an up-to-date kernel (which we know supports the wifi adapter) is it worth reporting this as a Qubes bug? Or are compatibility issues out of scope?

I might have seen “device not managed” before on some machine, and I believe I could make it work by attaching the device to sys-net with the permissive option (which might have security implications). See more here:

@427F11FD0FAA4B080123 Thanks for the tip, unfortunately none of the PCI troubleshooting steps seem to have helped. I tried:

  • permissive
  • no strict reset
  • both options

Each time I had to reboot the machine (not just restart sys-net) in order to see the Wi-Fi device under the network applet and get the “device not managed” error. If I just restarted sys-net I only got the Ethernet connection.

The additional device that appears alongside WiFi is “vif5.0” which seems to be a Xen thing. (It also says “device not managed”.)

I also confirmed that sys-net:

  • Is running the Fedora 32 template
  • Has linux-firmware installed (in the template)
  • Is running kernel 5.9.14-1
  • Has no obvious error messages in sudo dmesg

I may have to install another distro and revisit this after 4.1 is released. :unamused:

try the following command in dom0 terminal

qvm-prefs sys-net kernelopts ‘nopat iommu=soft swiotlb=8192 iwlwifi.disable_rxq=1’