`Insufficient free space` when upgrading to Qubes 4.1

Following the docs on upgrading to 4.1, I’m currently on 4.0, running it on Lenovo X230.

Running sudo qubes-dist-upgrade --all --keep-running sys-firewall, I’m getting this error:

---> (STAGE 0) Adjusting LVM thin pool metadata size...
  Rounding size to boundary between physical extents: 244.00 MiB.
  Insufficient free space: 3 extents needed, but only 0 available

Any ideas on how to solve this, or at least figure out what the problem is?

I tried to increase the disk space for sys-whonix (the vm downloading the update, I think), but that didn’t help.

I tried to decrease disk space for one of the big vms (thinking maybe all the disk space was already allocated for the vms), but that only messed up that vm:-) and didn’t help either.

Disk space in dom0:

$ df -h
Filesystem                   Size  Used Avail Use% Mounted on
devtmpfs                     1.9G     0  1.9G   0% /dev
tmpfs                        2.0G     0  2.0G   0% /dev/shm
tmpfs                        2.0G  1.5M  2.0G   1% /run
tmpfs                        2.0G     0  2.0G   0% /sys/fs/cgroup
/dev/mapper/qubes_dom0-root  174G  5.3G  160G   4% /
tmpfs                        2.0G   16K  2.0G   1% /tmp
xenstore                     2.0G  472K  2.0G   1% /var/lib/xenstored
/dev/sda1                    976M  209M  700M  23% /boot
tmpfs                        392M  8.0K  392M   1% /run/user/1000
$ sudo lvs | head
  LV                                                VG         Attr       LSize   Pool   Origin                                           Data%  Meta%  Move Log Cpy%Sync Convert
  pool00                                            qubes_dom0 twi-aotz-- 229.34g                                                         63.72  43.95                           
  root                                              qubes_dom0 Vwi-aotz-- 177.46g pool00                                                  5.14                                   
  root-autosnap                                     qubes_dom0 Vri---tz-k 177.46g pool00 root                                                                                    
  root-autosnap.tick                                qubes_dom0 Vri-a-tz-- 177.46g pool00                                                  4.54                                   
  swap                                              qubes_dom0 -wi-ao----   7.68g                                                                                                
  vm-anon-whonix-private                            qubes_dom0 Vwi-a-tz--   2.00g pool00 vm-anon-whonix-private-1660940875-back           25.12                                  
  vm-anon-whonix-private-1660940875-back            qubes_dom0 Vwi-a-tz--   2.00g pool00                                                  29.21                                  
  vm-anon-whonix-private.tick                       qubes_dom0 Vri-a-tz--   2.00g pool00                                                  0.21                                   
  vm-bx-private                                qubes_dom0 Vwi-a-tz--  14.00g pool00 vm-bx-private-1664822207-back               67.45                                  

Relevant: https://forum.qubes-os.org/t/4-1-not-enough-space-to-install-solved

I remove two template vms, each over 1GB, but it didn’t help. So clearly I don’t know what space is needed?

Tried to install kde-partitionmanager. It’s showing 1 device (ATA Samsung SSD), and 2 partitions:

  • /dev/sda1 ext4 (mounted /boot), 276M of 1G used
  • /dev/sda2 lvm2 pv [luks] (unmounted) 237G

Any advice how to figure out where do I need more space?