Installing Qubes OS on a 2018 MacBook Pro: Screen goes dark after clicking install

I am trying to install Qubes OS on my 15" 2018 MacBook Pro (Intel i7, 16gb ram), but the screen goes dark after I click the “Install” button.

Here are some details about my setup:

  • Mac OS version: Latest

  • Qubes OS version: Latest

  • Boot method: Bootable USB drive

  • Error message: two images in one below

  • Additional troubleshooting attempted:

    • Disconnected all external devices except power adapter
    • Tried booting in Safe Mode
    • Reset NVRAM and SMC
    • Disabled Secure Boot
    • Tried different USB drive and creation method (Etcher and dd)

I have searched online for solutions, but I have not been able to find anything that works.

Does anyone have any suggestions on how to fix this issue?

Additional information:

  • I have attached a screenshot of the loading screen that appears before the screen goes dark.

Thank you for your help!

The bootable USB just allowed me to install QUBES on a ThinkPad, which I did just to test the USB and Qubes themselves.

hardware compatability list.

You get through the setup, then click “begin installing”?

The problem is that after the logs I showed the screen goes dark… So I can’t do anything… Yet the fans start spinning.

I have seen installs where, when a particular point is reached, it goes a long time with only a single blinking short horizontal line. After awhile, it picks up and goes along.

However, I am not using an Apple anymore. It sounds like, when you divide partition, you are trying to accomplish a dual boot. Qubes OS with something else? When I had a 2009 MBP, Used to be Apple used to provide a means to do that besides just creating another partition.

Besides the fact I do not have the money to buy Apple products, one of the reasons I was not interested in having another MBP (of course a newer one) was because Apple Corporate, had become a bunch of control freaks. As the guy in the local computer store said, the reason Apple always works (well nearly always if you do things their way, not experimenting with Linux) is that they do not allow – this that or the other.

Which does not mean you can’t get Qubes working.

One of the things to consider, Qubes really thinks it should be the only OS on the computer. Apple does its own things to choose where it boots from when, that might be effecting what is happening. Notice Apple could not be effected by the malware related to “logo-xxx” because they had already encrypted their logo into their firmware.

Might be you can get some advice from Apple forums, but you sound knowledgeable enough that you probably are trying that. At least they might recognize the error message you are looking at. I don’t recall seeing it.

Creating the install USB, for some of us, has been strangely difficult. At least me. I am guessing you are using Qubes 4.1xxx. Which always seemed to me, got onto the install medium and pretty much just carried on. Well, except for the hang I mentioned, which I have seen go on for several minutes. I think it has something to do with the install deciding whether the graphics card can work, and then choosing some kind of alternate. That does not sound like the problem you have.

With Qubes 4.2 since the weeklies, and Release Candidates after RC2, I had more difficulties. All the time I spent trying to create a Qubes 4.2, was useless, I tried Rufus with Windows 10, different options. Etcher. My used to be-- my way to install Linux was to use Mint Linux, and use the Mint Linux USB tools. These appear to be the same USB tools used by Ubuntu. I said all that not because it has knowledge, just I understand your frustration.

I have a Librem 13, which in one way like Apple, it has its own proprietary BIOS/EFI. Which had been refusing the later versions of installing Qubes 4.2 (well since September 2023) I had gotten it to take Qubes 4.1 again.

I have no idea which thing I was doing which got it to work. But;
I suspected that one of the issues with the boot had to do with the fact the Librem 13 had, when I first gotten it, had refused to work when I tried to install Qubes again to the second drive. I should say, I got the Librem 13 used, and the slower drive was blank. That is, one of the boot issues had to do with the Librem 13 had two drives in it. I actually considered taking the drive physically out, or at least unplugging it.

What I actually did. I created a USB with Ubuntu. I booted the live version of Ubuntu on the Librem 13, and used it’s gparted to blank both drives. I first told it to format them to NTFS. then
formatted again to ext3. Leaving both the drives with nothing on them.

I took one of my later purchases, a USB drive that was USB 3 with the later protocol on it. Put it in a Windows 10 computer, and did a long format, not the quick format. I suspect a quick format only builds the partition table and then later it builds links through the drive. Unfortunately it was an unnecessarily long 128 GB drive. Formatted it to FAT32. I watched a movie and a half while it went on. I wanted to make sure no hiccups came from computer going into rest mode. I used the Mint Linux (latest) USB tool to install Qubes 4.2RC5. Librem 13 booted into it. Installed correctly. Appears to work fine.

Sorry to be so long winded. I don’t know the one critical thing that allowed the install to proceed. Maybe the Qubes folks did something to Qubes4.2RC5 that helped.


Edit: after using Gparted on Librem 13 SSD, I set the flag to make partition a boot.

I tried to create another USB, a much older USB, with Qubes 4.2RC5 with the same techniques. And the install will not proceed with the slower USB, I might guess, there is something to this about this timing during boot process. I have used the USB I installed correctly on the Librem 13 on several other computers, and installs of Qubes4.2RC5 worked just fine.

@Twolari Is there any chance of getting your model number?

It looks like this: “AXXXX” (usually an A, followed by 4 numbers).

I do know that the TPM in some of the last Intel Apple hardware did cause issues…

The fact that it couldn’t “find” the boot drive could mean anything, including the possibility that your USB drive might be faulty. Unlikely, but without further investigation, it’s still a possibility…


I couldn’t find that specifically, but below are the hardware properties.
MacBookPro 15,1

Woah! I got all that for free! Thanks!
The mac does have macos installed but the drive is not partitioned beyond Apple’s default. My plan is to boot into Qubes and install it on the only available partition, overwriting MacOS.

My boot USB is FAT32, I believe it should be good.

Also I was just successful with that USB, installing Qubes on a ThinkPad.

The installing Ubuntu and from there reset the NTFS might work, maybe Ubuntu will get rid of something MacOS does not like?

We will see! Thanks!

The bootable USB just allowed me to install QUBES on a ThinkPad, which I did just to test the USB and Qubes themselves.

Your model number is A1990.

Then you will definitely do well in this forum :sunglasses:


Just for now, don’t remove MacOS just yet. Not until we can be sure that we can get everything working properly (or you’re prepared to compromise).

Ok, so that rules out a bad USB stick, which is one less thing we need to worry about.

Ok, so here is a list of things that will drive you crazy about your MacBook when you’re trying to get Qubes OS to run properly:

  • The Touchbar
    - I have an A1706, and it’s a bit of a pain to get that stuff installed in dom0.
    - There are a few guides on this forum, and I wrote at least one of them.
    Another Attempt Made To Upstream An Apple Touch Bar Linux Driver - Phoronix
  • The ports
    - There are only 4 physical ports on the machine, but they will show up as multiple PCI devices (USB, Thunderbolt)
    - The internal USB keyboard, trackpad, and webcam are all on the single USB controller. This means having a USB Qube is possible, but you’ll have to trust all HID devices by default
  • The Broadcom Wifi
    - It might work out of the box, or you might need to install proprietary drivers/firmware into sys-net. I’m not sure. I don’t have your MacBook model handy, sadly…
  • A few other things, but they’re only minor…

@Twolari Does Fedora boot successfully?

Getting around the challenges you mentioned will only force me to learn more about Qubes :yum:.

I just tried Fedora in my Mac and boots with no issues (Fedora-Workstation-Live-x86_64-39-1.5.iso)

Including the Touchbar? So you have got access to function keys, right?

So, just to clarify:

  1. You are able to boot off the Qubes Installer USB by holding down the Alt/Option key when you power the machine on
  2. You are then able to successfully select the “Test this install media and install Qubes” option at the GRUB menu
  3. You are able to see the Anaconda GUI installer
  4. You are able to click the “Begin Installation” button at the bottom-right of the screen (like in this image):
  5. Your screen goes blank as soon as you click that button

Is this accurate?

That’s really odd if this is what’s happening…