Installing Qubes is IMPOSSIBLE. What am I supposed to do?

After hitting install Qubes after booting from USB this happens. Adding to the list each time I try something new.
Tried on 2 computers. One has Intel and Nvidia the other AMD

Ubuntu works just fine off this same USB

Qubes worked before off this usb on this exact same computer like 2 days ago so I don't see the issue

Formatted the USB using Rufus still doesn't work

Tried changing the bios from UEFI to Legacy

Tried Qubes 4.0 instead of 4.1

Switched to RAID in bios

Flashed Fedora to same usb and it works perfectly, just like Ubuntu did

Hi Fhesseti – welcome to the forum! :slight_smile:

Just to be sure:

You have the same issues on both machines?

To me it sounds like the Qubes install tries to do something, the Ubuntu/Fedora installer doesn’t do. Can you try to edit the options to the kernel and add



To edit the kernel options, press e when you have “Install Qubes OS” highlighted and replace the quiet with module_blacklist=amdgpu,nouveau

Hi Fhesseti, welcome to Qubes (almost).

of course, it isn’t impossible, it may be difficult or even
impossible for you, depending on what box you are trying to install.
That would be helpful information, but as you say it worked a few days
prior, I would focus on that box.
It would also be helpful if you said in what way the install fails.

Often Legacy BIOS seems an easier install, if that option is available.
I would use 4.1, and write the installer USB using dd in one of the
Live systems -
Change from RAID.
Check the hcl to see if anyone else has
used your computer and if so, if they needed any special parameters.

I never presume to speak for the Qubes team.
When I comment in the Forum or in the mailing lists I speak for myself.
1 Like

I ran into a similar issue after updating my motherboards firmware (bios), I use an AMD’s processor and GPU.
The solution that worked for me was to add x2apic=false to Xen cmdline when booting into the Qubes installation.

Note, it is also required after the installation is done.
Additional troubleshooting information can be found in Qubes’ github issues.

… but if OP is assured that “Installing Qubes is IMPOSSIBLE” then I don’t see how anything could help?

Two things can help: correcting the OP and not going off topic.