Installing Qubes having issues

I’m trying to install qubes onto a 1TB Partition, but I can’t even get close to the installer. I have no experience with this OS so I’m pretty clueless right now.

First, it got stuck on this stage for a long time.

Then, it started spamming these errors

After that, it moved to this for a couple minutes, starting an emergency shell? I have no idea.

I have never seen anything like this and am not sure what to do.

Overall, I am really confused at what’s going on. My hardware is an AMD Radeon 5600 XT, along with a Ryzen 7 3700X. I have 32GB of memory @ 3600GHz, a beefy 750W psu, a 4TB hard drive, and a 512GB NVME SSD.

Is it my hardware? What can I do to resolve this issue?

Thanks for any and all help.

EDIT: Fixed images

Which release of Qubes OS are you trying to install? - if it’s R4.1.2 (the current), did you try with “kernel latest” (last option on the boot menu)?

1 Like

Yes. I tried both options, those screenshots were from the kernel latest one. The R4.1.2 w/o kernel-latest stuck at the first screenshot. (Could’ve moved on if i waited longer, not sure)

Try to highlight kernel latest, hit e to edit the boot options and replace






Does that change anything?

1 Like

Do I try both? I’m currently trying radeon.

Try them one at a time – if one works, stay with that one … it’s a test to rule out the graphics driver as the issue.

1 Like

Should I try the other one, or let this one keep going as long as I can? It’s been stuck on this for a bit.

Both of them seem to have the same issues where they stall at this stage.

Not sure if this means anything, but I have a SSD (Fully windows), and then a HDD, which has a partition used by windows, as well as a blank partition that i plan to put qubes on (1TB). It’s just weird cause it seems like its accessing the NVME, which is the SSD. Not sure if this is part of the problem.

I am still having this issue. I have tried reimaging it onto the USB drive, but nothing has worked. I have no idea what’s going on here.

How did you create Qubes OS installer USB? You need to write the ISO in DD Image mode:
Installation guide | Qubes OS

I did it with balenaetcher. I will try this new method!

Seems not like the installation media’s error.

Error logs look identical to Installation failure on Ryzen 9 6900HS · Issue #7570 · QubesOS/qubes-issues · GitHub. Possible solution exists at Issues with Lenovo Yoga Slim 7 ProX (AMD Ryzen 6800HS) · Issue #7620 · QubesOS/qubes-issues · GitHub.

I’ll reproduce it in short:

you simply add x2apic=false to Xen’s CMDLINE

1 Like

Sorry, but how do I do this? I’m not experienced with modifying stuff like this

The XEN line should be the one above the kernel-line, when you hit e to edit the boot options. The kernel-line is the one with quiet.

1 Like

Alright, thank you. I will update this post once I get home and try it