Installing Qubes 4.1 On Partition with EUFI Grub Dual Boot

I have a dual boot Linux Mint and Windows 11 Installations on a NVMe SSD.
I want to install Qubes onto the same SSD and be able to tripple boot for now.
I want to see what Qubes is like to use.
I did try and install and it caused the SSD to boot only into Qubes.
I expected Qubes to give me some option to be able to boot the other operating systems. I obvioulsy should have done some more research on this.

So, how can I install Qubes so I can boot into anyone of the installed operating system?
I have Qubes currently installed on partition 4 but obviously cant get to it.
The Qubes architecture looks great for security.

I ran gdisk on qubes and went to the expert mode and recreated the gpt MBR so I could boot into grub.

Raymond Clements

If you want just to try Qubes, did you consider to install it to an usb instead?

1 Like

No I did not think about that.

I wanted the simplicity of being able to boot into it when I have some free time to try everything out.

Attaching a USB drive becomes a bit tedious and I have to change my bios to boot from it.

So I would prefer to install it on the same SSD as my other systems.

Would it be easier if I installed Qubes on another SSD and then add qubes to the grub menu or some how add my Mint and Windows 11 options to a qubes boot menu?


I think what you mention is grub os-prober, but since we are in uefi, why don’t create a new uefi entry, it’s much simpler.

When i said create a new uefi entry, that mean, use 1 efi partition for all os, then create entry pointing to the efi file, you could use efibootmgr to examine your uefi boot manager and create uefi entry.

1 Like

So I run efibootmgr on Linux Mint and that should pick up qubes?

not automatically, but manually.

as you stated in first post, you installed qubes in partition 4, but didn’t mention your drive configuration like, where is boot partition and efi partition, an example :

your qubes installed efi partition is 5, then the command is
efibootmgr -v -c -u -L "Qubes" -l /EFI/efi/grubx64.efi -d /dev/sda -p 5 this mean we do create an new uefi entry for qubes os.

what you have to do know is to do same step as above command, but change the efi file and efi drive pointing to your mint and windows.

A bit offtopic: is it possible to create such an UEFI entry for Qubes in BIOS?

no, how could it off topic?
but i think ts using uefi according to tittle.

The above is my NVMe SSD drive with the Windows, Mint and Qubes partitions.

P2 is Windows 11
P6 is boot and P7 /home for Linux Mint
P3 and P4 are for Qubes

So what command should I use to update grub so that qubes is on the Grub menu?


better provide fdisk -l and efibootmgr -v

Here is the output of the two commands:-

sudo fdisk -l
[sudo] password for raymond:
Disk /dev/nvme0n1: 476.96 GiB, 512110190592 bytes, 1000215216 sectors
Disk model: Sabrent
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: D1E507FF-C503-42A4-BC43-DDBACFDB26A7

Device Start End Sectors Size Type
/dev/nvme0n1p1 2048 1026047 1024000 500M EFI System
/dev/nvme0n1p2 1026176 156590079 155563904 74.2G Microsoft basic data
/dev/nvme0n1p3 658604032 660701183 2097152 1G Linux filesystem
/dev/nvme0n1p4 660701184 998895615 338194432 161.3G Linux filesystem
/dev/nvme0n1p5 998895616 1000214527 1318912 644M Windows recovery environmen
/dev/nvme0n1p6 156590080 265592831 109002752 52G Linux filesystem
/dev/nvme0n1p7 265592832 658604031 393011200 187.4G Linux filesystem

Partition table entries are not in disk order.

Disk /dev/nvme1n1: 232.91 GiB, 250059350016 bytes, 488397168 sectors
Disk model: Samsung SSD 970 EVO Plus 250GB
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xcf70c6b1

Device Boot Start End Sectors Size Id Type
/dev/nvme1n1p1 2048 488396799 488394752 232.9G 83 Linux

Disk /dev/sda: 465.78 GiB, 500107862016 bytes, 976773168 sectors
Disk model: Samsung SSD 860
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 04013BBB-DEC2-4287-B9E1-AD9DA7368A3C

Device Start End Sectors Size Type
/dev/sda1 2048 1050623 1048576 512M EFI System
/dev/sda3 1050624 976773119 975722496 465.3G Linux filesystem

Disk /dev/sdb: 447.13 GiB, 480103981056 bytes, 937703088 sectors
Disk model: SATA3 480GB SSD
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 7A1171A2-51DD-8907-2C5D-664C3F373763

Device Start End Sectors Size Type
/dev/sdb1 2176 937703023 937700848 447.1G Microsoft basic data

efibootmgr -v
BootCurrent: 0000
Timeout: 1 seconds
BootOrder: 0000,000E,0008,0004,0001,000A,000B,000D
Boot0000* ubuntu HD(1,GPT,e959f1fa-4fbc-4356-9285-b1e4ada191e6,0x800,0xfa000)/File(\EFI\UBUNTU\SHIMX64.EFI)
Boot0001* Qubes OS HD(1,GPT,e959f1fa-4fbc-4356-9285-b1e4ada191e6,0x800,0xfa000)/File(\EFI\QUBES\GRUBX64.EFI)
Boot0004* Windows Boot Manager HD(1,GPT,e959f1fa-4fbc-4356-9285-b1e4ada191e6,0x800,0xfa000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS…x…B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}…
Boot0008* Sabrent BBS(HD,0x0)…BO
Boot000A* Samsung SSD 860 EVO 500GB BBS(HD,0x0)…BO
Boot000B* SATA3 480GB SSD BBS(HD,0x0)…BO
Boot000D* Samsung SSD 970 EVO Plus 250GB BBS(HD,0x0)…BO
Boot000E* ubuntu HD(1,GPT,ea60fe63-140d-4199-a6a6-41f694a6f994,0x800,0x100000)/File(\EFI\UBUNTU\SHIMX64.EFI)…BO

It’s good that you only use 1 efi partition, have you try check in uefi settings ? there should be a boot order, you could arrange which one would booted fist, or you can access uefi entry directly by pressing f12 or f10, in my laptop the key was fn+f12.

or if you want to include it in your grub, try this :
edit this file /etc/grub.d/40_custom

menuentry 'Windows' {
    search --fs-uuid --no-floppy --set=root #efi_uuid
    chainloader (${root})/EFI/Microsoft/Boot/bootmgfw.efi

menuentry 'Mint' {
    search --fs-uuid --no-floppy --set=root #efi_uuid
    chainloader (${root})/EFI/ubuntu/shimx64.efi

change #efi_UUID with your EFI UUID partition, check by running sudo blkid -p /dev/nvme0n1p1 in dom0. example RTB1-BTR1

then run sudo grub2-mkconfig -o /boot/efi/EFI/qubes/grub.cfg