Installing HP printer and scanner on Qubes OS

Hi,

I have trouble installing HP LaserJet M1132 MFP printer and scanner.

I’ve created new qube for that purpose and installed hplip. Then opened HPLIP toolbox and I was able to install the driver. It said that driver was installed.

But when I refresh the list of printers/scanners, it shows me again that main window which says no devices are configured - and this time it doesn’t even see my printer to install.

Any help appreciated!

Thank you

I’ve had success running the hp-setup tool after running installing the hplip package. Is that what you did?

Hi, what I have tried was as follows:

  1. I’ve enabled network on the template which I use exclusively for HP printer and scanner.
  2. Started hp-setup from terminal (on template)
  3. Attached HP device
  4. Installed it (using ‘root’ as password)
  5. Installed plugin, which was requested by the application
  6. Restarted my laptop
  7. Started HPLIP Toolbox from qube (not template)
  8. Attached HP USB to qube
  9. Refreshed the whole list - nothing was on the list
  10. Started hp-setup from HPLIP Toolbox
  11. Could see “No devices found”

Basically, the steps 10 and 11 seems unnecessary for me but as step 9 didn’t show my my printer, I’ve also tried with those. In other words, it was successfully (or at least it looked so) installed on the template but I cannot use it on the qube. Thanks!

I may be missing something but why do my spidey senses tingle at this?

Not sure if it could be this but I’ve never actually installed it. Maybe try doing the process on an appvm and see if it does work. If it does, then it’s an issue with the hplip tool storing files in the template’s user directory which gets overwritten when you open an appvm based on that template.

@Plexus: Probably I also miss something. This is not the password I’ve set, it worked like this by default (just tried with empty pass, it didn’t work, this with pass the same as user and it worked). I guess it’s default password in the templates. Could it be right? Anyway, computer is protected by encryption and anyway the DOM0 doesn’t require any specific password (although I almost never need to do anything there). Is there any way to enforce some password on DOM0 or templates? Or do I miss something important here?

@deeplow: I was able to “install” in on the qube but then there was the same problem - it claimed that it was installed but I couldn’t see the scanner/printer when I refreshed the list of installed devices. I don’t know what is wrong here.

@newqubesosuser honestly ive never tried to enter root passwords in qubes, as sudo is passworldess in qubes.

Yes. Maybe doing sudo hplip. There’s no risk in doing that in Qubes.

Then there’s also this guide in the community docs, but I’m not sure it is of value here:

Thank you. I can run sudo hp-setup (but sudo hplip shows nothing). I can install with sudo hp-setup and it seems to work but later there is nothing in HPLIP that I run from the qubes menu. Maybe if I could run sudo hplip-gui from terminal that would help - but hplip or hplip-gui shows ‘command not found’, I can only start ‘hp-setup’ and ‘hp-plugin’ from terminal and HPLIP from the Qubes menu. If, after “successful” installation I run HPLIP from Qubes menu, it doesn’t even see the printer (I’m sure it’s attached to template qube). Similarly on ordinary qube (not template).

sudo apt install hplip-gui shows that it is already installed in the newest version

@newqubesosuser wrote:

If, after “successful” installation I run HPLIP from Qubes menu, it
doesn’t even see the printer (I’m sure it’s attached to template
qube). Similarly on ordinary qube (not template).

I am not sure if I get the gist of your question right. I do use a HP
LaserJet like this:

  1. In the template I install hplip and hplip-gui as well as
    qubes-usb-proxy obviously

  2. I attach the printer to the template and run sudo hp-setup

  3. Shutdown template and start actual qube you want to print from (it’s
    important that that qube was (re-)started AFTER you shutdown the template.

  4. Attach the printer to that qube (not the template anymore!)

  5. Print

Can you try the above steps and tell me where it fails for you?

Thanks. Actually, I have done earlier second step in different way because this way I receive the following:

sudo hp-setup
HP Linux Imaging and Printing System (ver. 3.18.12)
Printer/Fax Setup Utility ver. 9.0
...
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
Searching... (bus=usb, search=(None), desc=0)
error: Unable to load Qt4 support. Is it installed?
Traceback (most recent call last):
 File "usr/share/hplip/ui5/setupdialog.py", line 1296, in NextButton_clicked
  self.showDevicesPage()
 File "/user/share/hplip/ui5/setupdialog.py", line 561, in showDevicesPage
  smart_install.disable(GUI_MODE, 'qt4')
 File "/user/share/hplip/base/smart_install.py", line 235, in disable
  dialog.exec_()
AttributeError: 'NoneType' object has no attribute 'exec_'
Aborted

So this may be the cause of this problem I have. Please advise.