Installing and using an HP Colorjet multifunction printer

Hello all,

I have set up a test system for Qube’s OS to first test whether it is usable in my everyday life, since I am actually a Windows switch. Well, I know my learning curve is very wide at the moment, I understand most of it and read a lot.

Now to my main problem at the moment,
I have a multifunction device HP Color Laser MFP 178nwg

With this I want to print and scan. Now I have built a new Qube test and try there to make the printer / scanner usable. Now after 4 days of continuous search and tinkering of unsuccessful I try my luck here.
I tried to download and install the driver for Linux from the official HP site. This also works and in Print Settings I have added this and printed a test page. So far wonderful. However, when I shut down the VM and restart it, the printer is gone and I have to add it again. I tried this with a new Cube under Debian template but also tried with the preinstalled Qube Personal (yellow). With both the same, the printer is gone after shutdown.
Scanner I could not find anything now how I can add and use this, he simply finds none.

Next I tried HPLIP.I installed HPLIP and HPLIP-GIU. There it finds nothing at all. I can ping the printer/scanner and it responds, but it doesn’t find anything under the IP in the HP setup.

Do any of you have a tip for a newbie on how I can now set up the printer and scanner in a Qube created specifically for it?

Thank you and best regards
mikcor

You need to install the printer drivers onto a template qube (on 4.2 named debian-12-xfce, fedora-38-xfce, etc), not an AppVM (personal, vault, etc).
AppVMs will rememember for example your browser bookmarks but will take their kernel and apps from the template VM. If the template does not have the printer drivers, after reboot of AppVM, the drivers will be gone.
You can go to Qube manager to also see which application is a template or AppVM.

Okay thank you, It is running now. Does anyone have an idea how I can add the scanner of the multifunction printer. Is there a setup to add the scanner?

I ultimately had to install three or four of the generic Linux scanner packages. They all sucked, to be honest, but some had less suckage than others.

do you mean the drivers or a scanner setup app?

Perhaps I lack understanding here as well. I got the printer installed via system-config-printer.
I am now actually looking for the “system-config scanner” to add this. I have already downloaded the drivers from the HP site. I am missing a scanner setup app (like system-config-printer for the printer).
Ahso this is a multifunction device with me.
Maybe someone can help me. Thank you guys.

I meant an app.

Hplip apparently set up my scanner properly, but without an app to run it, it might as well not exist.

The first clue for me was noting that the scanner didn’t think it was connected to a computer. (It has to push the data it reads somewhere, whereas a printer receives data from the host suystem). Once I installed apps they knew what to do to make the system visible to the scanner.

1 Like

okay, I have now tried to set up the HP network printer on my new computer. What always worked suddenly no longer works. I have installed the system-config-printer. I downloaded the driver from the HP printer and installed it in the template. The problem is when I call system-config-printer, I can’t add a printer because the “add” is grayed out and I can’t press anything. This is the case with both templates (Fedora and debian). What have I done wrong?

If I enter 192.168.0.172:631 above in the browser it finds the printer. If I enter localhost:631 it does not find the printer

best regards

Is cups is enabled ?
The add button is grayed out if not.

[user@some_qube ~]$ systemctl status cups

seems to be disabled:

how can I activate it with which command?

in dom0 terminal:

[user@dom0 ~]$ qvm-service some_qube cups --enable

(or select cups in the services tab of the app qube settings)
Restart your printer app qube after entering the command (or after selected the service in the tab setting).

In system-config-printer, when you will click on the add button, you will probably be prompted to enter a password.
To add a printer, you need to launch system-config-printer with root privileges.

[user@some_qube ~]$ sudo system-config-printer

Should I enable cups in the template or in my “printer” cube? Then another question, do you have a solution for me or for the scanner? It’s a multifunction printer. I have already installed HP drivers in the template

Thanks you for your help

In your printer qube.

Unfortunately, I don’t have experience with scanner.

I would follow what @SteveC said. Apparently, system-config-printer doesn’t handle the scanner.
So you need to install an app for it.

You can probably found that info with a search engine :slight_smile:
Assuming you got Fedora:
https://www.startpage.com/do/search?q=fedora+scanner+app

Maybe:

sudo dnf install simple-scan
# for debian, seems to be the same name

or

sudo dnf install xsane
# for debian, seems to be just: sane

You can make a new qube to test out which one works.

Simple scan is the one I settled on; it seemed more willing to accumulate scans into a PDF file. But you have to work to find all of the relevant parameters when you set up a scan, they’re scattered all over the place on multiple tab pages. Horrible UI design.

I really didn’t like any of the options. Back when I was running VirtualBox on Ubuntu I had access to a simple app that just did what I wanted it to without insane hoop-jumping.

hmm which password and user name? Nothing works, no password works?

To add a printer you need to launch system-config-printer with sudo.
No use/password will be asked.

okay thanks that was my mistake. But I had to add the printer to the template, because it was always gone in the Drucher VM when I restarted it.

Thanks again. Now I’ll have a look at the scanner and see how I can get it to work.
Regards