Installer Freezes


I tried installing QubesOS on my PC but the system freezes before showing the installer.
I can see a boot process which seems to work fine and then I see a new screen starting with “Starting installer, one moment” which is instantly freezing the whole system after line number 6 “19:21:19 Not asking fort VNC because we dont´t have a network”

I tried to follow the instructions from UEFI troubleshooting | Qubes OS but there is no file EFI/BOOT/BOOTX64.cfg. I guess this seems to be replaced by grub.cfg in the current version but I cannot find the parameters there and the structure of this file is also pretty different.

Fedora works fine on this PC.
Hardware is AMD 5800X + AMD Radeon 6900 Graphics Card.
EFI is configured to pure EFI mode. If I change this to EFI + Legacy the behaviour is similar for EFI boot. Legacy boot even crashes earlier with almost no output.

Any ideas on how I could solve this issue?

Hekki and welcome.

You may want to try

and to search the forum/

Did you try to disable secure boot in BIOS?

1 Like

That would only work on a Qubes OS install, not on the ISO itself. Those files are tucked away inside /LiveOS/squashfs.img, and you shouldn’t need to touch any of those :laughing:

@jdw, that sounds like there’s an Xorg error.

Without knowing any of the details about your hardware configuration (other than the fact that you’ve got a discrete GPU), my guess is that the X server has started on your integrated graphics display, instead of your discrete GPU…

If you try to go to another tty (Alt + Ctrl + F2), what happens?

If you are able to get a terminal on tty2, what does the output of xrandr say?

@enmus is right. This will cause you a bit of grief if it’s enabled. But the fact that you were able to progress so far through the boot process suggests that your issue lies elsewhere…

Still, it’s a good idea to disable it :slight_smile:

Thanks for your reply.
I did search the forum but I did not find any solution.
The issue in the linked thread seems to be related to nvidia gpu and also has no resolution.
Secure boot is disabled.
The system freezes completely and I cannot press any key or switch the terminal. Even if I press num lock key the LED stays on so the system is completely unresponsive and I only can power it off.
The system does not have an integrated gpu. The mainboard support CPUs with integrated GPU but the 5800X does not have any. Maybe xorg tries to start the integrated GPU (which is not available)? Can I somehow force the installer/xorg to use the dedicated GPU?