Installed Qubes on secondary SSD; boots into first drive

Correct, I was able to install Quebs OS on it whoever, now BIOS is not giving me an option to boot from it…

Can you try to remove the first SSD and see if Qubes would boot? Can you try to press F7, F8, or F12 during the boot to attempt to have a “boot device” choice?

Also, perhaps you can search your device model in the Internet and find how to choose boot device in BIOS.

Hi fsflover,

Thx for recommendations. I will try to remove first SSD and see if that work. Regarding other suggestions, I already did it, and BIOS did not give me that option.

Perhaps you can update your BIOS, depending on the laptop model.

I had updated BIOS 3 weeks ago; maybe I try to downgrade it?

In case you had such option before, then it might be reasonable to downgrade. However take into account that you may also remove bugfixes in this way, which may negatively affect your security.

See what I have done:

  1. I removed my Linux Mint Nvme drive reboot laptop, and no positive results. Went to BIOS to check if this drive is visible to the system and BIOS say YES it is visible but still can’t boot from it
  2. I install quebs os on another Nvme drive and added to my laptop, went to BIOS, it says that two disks are available but when to try to reboot it doesn’t give me a bootable disk option
  3. I removed one Nvme disks and installed standard 2.5" hhd; installed quebs - with no problem. Reboot laptop and again no bootable disk available.

I’m starting to think that there is something wrong with my Quebs installation USB, but when I’m going to check media, the verifying process tells that this media is ok to install from.
I have no idea what to do next. Please help.

1 Like

i one had a somewhat similar issue… -years a go an not exactly so…
but the issue i had was a corrupt “broken” mbr
which basically go ignored by the uefi/bios
would work if “forced” but whenever there was another gpt drive th system will just automaticlly boot the gpt drive

soled this by completly repartitioning and repairing the mbr
was a bit of a pain in the ass for a number of reasons… ()first it was a pretty big drive and i had to backup everything -and well had other issues corruption did no only effect mbr but… -let me tel u somthing the software called testdisk is great for data recovery but horrificlly slow)

anyway way
check how you’re drive’s partitioned maybe that’s the cause/related

also try using another disk usually when the isue is with the component instead of system/ what’s installed on the component using a different one will reveal where the problem is
if u tried different drive etc then the issue is probably somewhere else such as in your bios

Thx JustAUserMan

I tried different SSD, HD. I did use another USB stick with the other method of creating them(Rufus, dd) nothing works :frowning:
I changed BIOS settings and still nothing.

Did you check the digital signatures of Qubes iso? Did you try to install some other OS on that hdd?

Thank you for helping me.
I did not check the digital signature, and no, I did not try to install another os on that HDD, yet.
That is good suggestions. I will do it today.

1 Like

I can say that now I have checked ISO and all is OK and verified.
I did install anther OS on this Drive and BIOS does not allow me to boot from it.
My laptop is DELL G3 3579 - maybe there is something in BIOS that I should change?

Does your BIOS boot with UEFI or Legacy? If your BIOS is not able to find a UEFI partition, maybe this post could bring ideas? Cannot boot from SSD after installing a secondary Qubes to a USB disk

Thank you, katiehill. On my BIOS I have UEFI and Legacy available. I will read your suggested post straightaway.

I fallowed suggestions from recommended posts and after completing them I have below results on terminal:
efibootmgr: ** Warning ** : Boot0007 has same label Qubes
BootCurrent: 0006
Timeout: 0 seconds
BootOrder: 0008,0006,0001,0002,0003,0004,0005
Boot0000* ubuntu HD(1,GPT,fe6ecd13-90d0-4840-be2e-6cec8505fa2e,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot0001* Diskette Drive BBS(Floppy,Diskette Drive,0x0)…BO
Boot0002* USB Storage Device BBS(USB,USB Storage Device,0x0)…BO
Boot0003* CD/DVD/CD-RW Drive BBS(CDROM,CD/DVD/CD-RW Drive,0x0)…BO
Boot0004* Onboard NIC BBS(Network,Realtek PXE B3C D00,0x0)…BO
Boot0005* UEFI: KBG30ZMS256G NVMe TOSHIBA 256GB, Partition 1 HD(1,GPT,fe6ecd13-90d0-4840-be2e-6cec8505fa2e,0x800,0x100000)/File(\EFI\boot\bootx64.efi)…BO
Boot0006* ubuntu HD(1,GPT,fe6ecd13-90d0-4840-be2e-6cec8505fa2e,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot0007* Qubes HD(1,MBR,0x6d87b34a,0x800,0x200000)/File(\EFI\qubes\xen.efi)
Boot0008* Qubes HD(1,MBR,0x6d87b34a,0x800,0x200000)/File(\EFI\qubes\xen.efi)
Please advice what next?

Your problem made me think of a problem I had. If the root of your problem was the same as mine, I thought you could use my solution to my problem one way or another to help you solve your problem.

I’m certainly not a Qubes expert, nor a UEFI/BIOS/Legacy expert!

So I don’t know what to advice next. Maybe start from man efibootmgr and see if you can tweak the options to help you? Or maybe somebody more knowledgeable than us will point you in the right direction? Hopefully so!!

Does anyone know, what types of files, what content and where exactly must be to have Quebs boot? I might put them manually into the right place and see if that makes any difference.

Sorry, off-topic: just tiny correction since you’ve said it multiple times: it’s Qubes, not “Quebs”. (some month ago some guys on youtube called it “Quebs” and you might have picked it up from there)

Noted :slight_smile:

1 Like

How did you fix the issue and booted? Was this issue solved?