Installation report :: partitioning+Add-ons

Hello all, I hope that’s the right section to report installation gotchas and ask questions about it !
I’m using two disks only for now : 40GiB for boot+root and a 4GiB for swap.

Partitioning report

Automatic partitioning didn’t work, but that may be expected with this setup (I don’t have any experience with Fedora installs).
When I go to manual partitioning, after I successfully create boot then root on the 1st disk (sda), I cannot add a swap partition on the 2nd disk (sdb), I’m told “no space left”. Of course I previously de-selected sdb on boot and root in “Device(s)->Modify”.
The solution is to create the swap partition first and de-selecting sda from it.
There should be a “device selection” when selecting mountpoints in anaconda, but I guess it’s not Qubes related but rather a Fedora problem.

I encountered another problem, after partitioning correctly. I’ve set a really short passphrase for now (1234), plannign to change it later, and even if the installer showed me “the key is too short”, it didn’t prevented me to continue, so I thought that would be handled like a short root password, but no !
The GUI installation stalled at “Created luks on /dev/sda2”, with an error message (that I didn’t copy, but from memory it was “Incorrect passphrase”). In the logs, I see “pyanaconda.[…].errors.installation.StorageInstallationError: Failed to activate device: Incorrect passphrase”.
I reported the error on the RedHat bug tracker.

Add-Ons report

I know I can install the templates later after install, but I just wanted to report that I was only presented with “Qubes UI (Audio/Gui)” in the Add-Ons, not any template like on the install guide. I’m using “Qubes-R4.1.0-x86_64.iso” (5.5GiB)

1 Like

Ok after many retries, I’m unable to make crypt working, I always get “Invalid password”.
I’ve tried :

  • automatic partitioning
  • manual partitioning
  • advanced partitioning using the “Custom LUKS config” from this guide

With custom luks config, I do:

cryptsetup -v --hash sha512 --cipher aes-xts-plain64 --key-size 512 --use-random --iter-time 10000 --verify-passphrase luksFormat /dev/sda2


cryptsetup open /dev/sda2 luks

I always get “no key for this passphrase”. I’ve even tried dead simple passwords to no avail.
What’s wrong ? Am I the only one in this case ?