Installation problems on Dell XPS 13 9310

Hi Cubes-Community,

I have problems with the Qubes installation on Dell XPS 13 9310. (probably because of the intel Iris Xe)
With default BOOTX64.cfg i had a blackscreen.
After hours of reading troubleshot and forums the qubes-verbose part is the following:

[qubes-verbose]
options=console=vga efi=attr=uc
#noexitboot=1
#mapbs=1
kernel=vmlinuz inst.stage2=hd:LABEL=Qubes-R4.0.4-x86_64 i915.force_probe=*
ramdisk=initrd.img

Now I see after starting the installer at least a mouse, but no GUI starts.
According to the notes from https://groups.google.com/g/qubes-users/c/P5oXyk7QOFE/m/hEROXm0tBQAJ

"make sure networking is attached to bring up GUI.

I had to combine sys-net and sys-usb in the install options because I was using a docking station for ethernet."

Is it really necessary to be connected to the internet for the gui? How can i combine sys-net and sys-usb to install with Network connection? (notebook has only usb-c inputs, ethernet only with docking station)

All other options like

nouveau.modeset=0 iommu=no-igfx

or

efi=no-rs

had no effect. Legacy mode is also not available.

I know 4.1.0 is only a test version, but would it be an alternative if necessary? There a GUI is displayed and I can install qubes. However, no templates are installed. In the Template configuration window all options are gray and not selectable. Default dropdown empty. Also under /mnt/sysimage…/ the template folder is empty.

Hope someone can help.

Try 4.1 it works very well with dell xps 9310

thank you for your answer. 4.1 installation works, but unfortunately there is also the network problem. The Ethernet port of the docking station is not recognized. With an offline installation there is no template available.

Qubes initial configuration failed. Login to the system and check /var/log/salt/minion for details. You can rentry configuration by calling 'sudo qubesctl --all state.highstate' in dom0 (you will get detailed state there).

that means after the installation there is no sys-net, etc. templates are completely empty.

could you solve the problem?

try using fedora as default template.

Maybe you have not finished your install properly…I installed it on a friends 9310 a few days ago and it was working perfectly…

Try to install it again…after the initial install it tells you to reboot…leave your usb in the computer…it then will walk you through the rest of the process…there you can decide which templates are to be installed, wether you want to use whonix for updates and you can decide upon you initial appvm setup…

very strange, what am I doing wrong?

i have reinstalled it several times now but always with the same result (see picture). usb stick is connected all the time, docking station with ethernet too. partitioning was created automatically.

there is simply no template at all :frowning:

redownload iso, use automatic partitioning.

That’s it! :astonished:

i have now reloaded the iso and changed the usb stick to a usb-3 32 GB stick. (i only had a usb-2 8GB stick before because the instructions said that bigger sticks could cause problems). isos have the same (correct) hash.

I don’t know what the problem was but it works now! Thank you both so much for your time and help.