Installation problem with Ryzen 9 6000 serie


I have a Beelink GTR6 (the CPU is a Ryzen 9 6900HX) and I have trouble with compatibility (?).

When I do the normal installation procedure (booting from a USB key) I don’t even reach the installer (problem with the device slot ID assignment, see picture of this post: https://

When I disable IOMMU in the BIOS, I manage to install Qubes on the SSD but of course, sys-net and usb are not working. (Can’t do anything without keyboard)
Then, when I am activating IOMMU again, Qube is not starting. I am stuck on “reached target basic system”

Am I doomed to wait for version 4.2 and hope it will be solved ? Or what else can I do? I also tried 4.1.2 and 4.0.4 , but without success.

Thank you!

This may be of interest: Ryzen 7000 serie

There are other similar topics on the forum.

I agree, from what I gather from researching this exact topic is: The issue is with Xen. Qubes needs a newer version of Xen to support this newer hardware.

1 Like

Solved with x2apic=false

This topic helped me: Ryzen 7000 serie

As said before, it’s a problem with Xen :+1:t2: