Installation Problem. Qubes 4.2.0 Install Fails Thinkpad T15

Thinkpad T15 Gen 1:

Intel i7-10510U
Intel UHD 620
Nvidea Force MX330
Intel Wifi 6 AX201

While trying a fresh install of Qubes 4.2.0, the installer gets stuck at qubes freeze “xen_acpi_processor: Uploading Xen processor PM info”

According to this thread, I am blacklisting the xen_acpi_processor module:

modprobe.blacklist=xen_acpi_processor rd.driver.blacklist=xen_acpi_processor

After that, the installation continues and eventually hangs according to the screenshot.

Additionally, I have temporarily disable nouveau:

nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off

Some notes from troubleshooting:

  • The result is the same when booting in Legacy or UEFI mode.
  • The install USB was properly verified and used successfully to install Qubes 4.2.0 on another system (a Thinkpad T450s).
  • The T15 BIOS is up-to-date.
  • The UEFI troubleshooting docs look to be out-of-date (eg. there is no longer an EFI/BOOT/BOOTX64.cfg file to modify, just grub.cfg).
  • I played around with kernel parameters to no real effect. Disabling modules changed the text output a bit, but the system still froze at around the same point.

I’m unable to proceed further; the installer is stuck. Does anyone have any suggestions on what else I can try?

Thank you for your time and help.

Hi :slight_smile:

This is a “random” link from the forum - I don’t know if it will give you more debug information (I’ve not tried it myself) - but sounds like it could help:


Using the command line options

(multiboot2 line): loglv=all guest_loglv=all vga=,keep For kernel command line
(first module2 line): console=hvc0 earlyprintk=xen

The boot process runs slowly, so it can be read, but I could not detect any errors. The
system continues to hang around the line:

“xen_acpi_processor: Uploading Xen processor PM info”

Next, I installed the still supported version Qubes 4.1.2. The installation runs smoothly and the system is operational.
Then, I attempted an in-place upgrade from version 4.1 to 4.2. The reboot after Stage 1 - 3 of the installation resulted in a black screen without any error messages, and booting into the rescue system was not possible.

Current status. My system is not compatible with Qubes 4.2, but it is fully operational under 4.1.

Maybe someone has a thought.

Can you try to add the debug options to the in-place [partially] upgraded installation - and confirm that the issue [still] is around the

xen_acpi_processor: Uploading Xen processor PM info


Sorry that I don’t have solution to your issue - but confirming that the place of the issue is the same, could help others to suggest options.


I don`t have any debug information regarding the in-place upgrade. The system could not be restarted. Black screen, and even the rescue system did not start.

A complete reinstallation Qubes 4.2 always hangs at:

xen_acpi_processor: Uploading Xen processor PM info

Have you tried this:


– again it’s just a random search of the forum, so it might not fit your issue …


This issue describes the same problem and unfortunately, it is still open. For one user, the installation worked with:

modprobe.blacklist=xen_acpi_processor rd.driver.blacklist=xen_acpi_processor

but unfortunately, it did not work for me, that’s a shame.