Installation of QubesOS on NVMe (OLD motherboard)

I have an issue. I am trying to install QubesOS on my NVMe M.2 SSD. It is connected through a PCIe adapter card ( My computer is an OptiPlex 7020 SFF (Dell OptiPlex 7020 SFF – Specs and upgrade options) so the motherboard is a bit old. I updated BIOS to A18 (it was on A04).

Long story short, I believe I installed QubesOS correctly on the NVMe drive but it only loads into QubesOS from my HDD. I am in UEFI mode (my bios has almost no other customization options because it’s so old). Not sure what else I need t odo to get this to work. I am going to reinstall again, but if anyone can tell me what I am missing or give me an idea of what should be done during install and after to get it to load the NVMe drive.

I was messing with some GRUB Commands, GPT said something about set root=(hd1,msdos1) which works, then it says to do linux /vmlinuz root=/dev/nvme0n1p3 but /vmlinuz isn’t found, I am not sure where to find the path to the kernel and initial ramdisk.

If I am going about this the wrong way, let me know. I want to learn what I’m doing wrong.

I use Qubes R4.1.2 on a similar vintage laptop (i7-4710HQ) and had the same issue. I tried many, many install options/drives but for Qubes to install on the M.2 drive I had to select only the M.2 drive during installation and not any other drives. When I selected both an M.2 and HDD during installation it always loaded Qubes on the HDD, no matter what options I selected.

Turns out, that worked better for me by helping speed up the system. I now attach the HDD after boot, but only when I need it. And that turns out to not be that often.

Well, I got mine to work yesterday. I used a pre-built ISO of Super Grub2 (a 2015 version so it would be more compatible with my old 2014 CPU/Motherboard). It immediately recognized the NVMe, because my Motherboard’s BIOS didn’t have NVMe drivers. Super Grub2 bypassed that (so does dEFInd and a few others).

Now, I need to format my old HDD to use as extra storage (not sure how to connect qubes to it and such but I’d like to have it store certain less-used things there, if anyone knows a good guide)

And, more importantly, I now need to do a GPU Passthrough, which may be easier than I thought because I have a very old AMD 1gb PCIe card (and Intel integrated graphics). So if anyone would walk me through doing this and setting it up, I’d appreciate it!

Hell, I’ll even pay you money if you’ll help me finish setting up the rest of my stuff (Having trouble with Proton VPN through Wireguard/OpenVPN) haha

Yes, my laptop BIOS doesn’t recognize NVMe either so I’m using the earlier AHCI based M.2 drives (either a Samsung XP941 or the early SM951 before they switched it to NVMe). I can hack the BIOS to use NVMe but focusing on the security Qubes provides that sounds like a bad idea.

With that said I hope someone who has used SuperGrub2 to bypass the BIOS can chime in. My first impression is not to use it with Qubes, but their may be other security-related perspectives.

I recommend reading the Qubes documentation for formatting/hooking up other drives, among everything else.

Yes, I have Super Grub2 on a Flash Drive and not directly installed, but ideally I am going to have a better, more permanent option installed as a boot partition on my HDD. I need to wipe the HDD and I may install an OS for gaming on there (Windows Paranoid {which is completely stripped down for privacy} or a Manjaro Gaming OS) while I mess around with and attempt a GPU pass through. I may not even have to do any GPU pass through if I get a Ryzen 5700G, the integrated graphics is about equal to an RX 550 I believe which should be plenty for most any game.

But if I get the cpu, I’ll still need to get a cheap AM4 so et mobo and at least 32gb ram, and money is still tight for a while so I’ll keep working on the gpu stuff and enjoy a Manjaro or Windows dual-boot. But that may prove difficult as well… Guess I’ll find out today as I try it out.