Installation Media Stuck on Black Screen after Anaconda Starts

I’ve looked over the threads with similar issues, but no one seems to have the same issue as mine. During the installation process, I get stuck on a black screen with a cursor in the top left after the “anaconda” window pops up.

I’ve waited at this screen for a good 10 minutes or so, with no changes. I’ve tried everything I could think of to escape it (ctrl alt f4, ctrl alt f2, all the function keys on their own, ctrl c, ctrl z, etc.) but got no response whatsoever.

Based on the docs I assume it shouldn’t affect such an early part of the installation process, but yes, Intel Virtualization is on, I have an AMD video card (some people have issues with nvidia, it seems…), etc.

I’ve attached an image of the last screen I see before the black screen.

Update: I tried using the media on my laptop and it opened the graphical part of Anaconda with no issues and no delay.
General detail about my desktop, not sure what could be causing this:
mainboard: MSI MAG B660 TOMAHAWK
cpu: Intel 12th gen i7 12700
gpu: AMD RX 6800 XT (I have two monitors plugged into this via displayport)
memory: 32 GB

I guess the driver for a AMD RX 6800 XT would be the amdgpu module - have you tried to add
module_blacklist=amdgpu to the kernel line at boot?

To edit the commandline at boot, press e when you have “Install Qubes OS” highlighted - it should show you something like:

setparams 'Install Qubes OS'

  multiboot2 /images/pxeboot/xen.gz console=none
  module2 /images/pxeboot/vmlinuz ... quiet
  module2 /images/pxeboot/initrd.img

The line that ends with none is the options for Xen (the hypervisor) … and the line with quiet is the kernel - so if you replace quiet with module_blacklist=amdgpu it should show more information and disable the amdgpu module.

1 Like

I had the exact same problem with QOS 4.1.1 on Acer Nitro 5 and eventually gave up and moved back 4.1.0.

Thank you so much!! This has solved MOST of the issue. I was able to load Anaconda and install Qubes.

However, both within Anaconda and subsequently when booting Qubes, everything was extremely laggy - my mouse updated at about once per second, and every time something on the screen moved or changed, the screen would slowly “paint” the new frame over the screen, from top to bottom, taking about two seconds. There are occasional spurts during which my mouse will move at a normal refresh rate. Typing things is usually normal.

I was thinking it might be because of disabled graphics drivers. I tried doing sudo modprobe amdgpu but it failed to load the module. I’m coming from Arch, and I couldn’t find anything in the documentation for Qubes about how it handles loading kernel modules. Is there a way I could enable this? Does Qubes even support my GPU, or will I have to wait? (I’ve heard that Qubes doesn’t always do great with modern hardware.)

Also, it’s not recognizing both my monitors, but I haven’t troubleshooted that yet and will probably make a separate post for it if I run into issues there.

Have you checked, if the module_blacklist=amdgpu was added to the GRUB menu on install (sorry - I don’t recall if the installer automatically does that :-/)?

When you have the boot-menu, press e to edit and look for the kernel line (should still have quiet, iirc). If it has module_blacklist=amdgpu, then you can remove it and see if the machine will run with it (ctrl-x to boot). I would also consider trying the kernel-latest – but be warned, that it could put you in harms way:

– but testing kernel-latest on a fresh install, might be the right time to do experiments … if it doesn’t work, the loss will be minimal. :wink:

So if you are prepared to risk a new install, you could run this command in dom0:

sudo qubes-dom0-update --disablerepo=* --enablerepo=qubes-dom0-current-testing kernel-latest
1 Like

Thank you again for your help, it’s greatly appreciated. This post might be a little tediously written, and I apologize for that, but I want to be thorough for the sake of anyone reading this in the future, either with a similar issue or looking to fix the issues I’m having.

Have you checked, if the module_blacklist=amdgpu was added to the GRUB menu on install

Yes, it was added on install. When I removed it and tried booting from there, both monitors worked and I was presented with the disk unlock splash screen. Interestingly, the splash screen only displayed on the other monitor that hadn’t worked before - the other monitor displayed a terminal. However, the graphical feedback for typing in the disk password was extremely laggy, and once I entered the password, it got stuck with the progress bar halfway across. When I pressed the power button to shut down, the splash screen appeared on both monitors as it shut down.

Then I installed kernel-latest and tried booting again. First I tried booting with module_blacklist=amdgpu still present in the boot options, to see whether the kernel alone changed anything. I didn’t get past a terminal, never saw the disk unlock splash screen.

After that I tried booting with kernel-latest and without module_blacklist=amdgpu, since this would logically work better. It behaved very similarly to the first attempt without kernel-latest and without module-blacklist=amdgpu, the only differences being:

  • the graphical feedback for password entry on the splash screen wasn’t laggy at all
  • instead of getting stuck halfway, the progress bar got stuck at 100% and nothing happened from there.

Similarly to the first attempt, the splash screen appeared on both terminals after a short press of the power button.

All in all, unless you have a new idea for me to try out, I’m guessing there’s not going to be any way for me to run Qubes on this hardware for a while, until support is added. Thanks again for your time!