Installation issue in boot from USB, "error: no multiboot header found"

After downloading qubes 4.1 from the downloads section, I ran “sudo dd if=Qubes-RX-x86_64.iso of=/dev/sdb1 status=progress bs=1048576 conv=fsync” from a linux machine to create my usb bootable drive. From my Dell Latitude E5440, I chose “UEFI:General Flash Disk 8.07” from the boot menu (with USB in slot of course) and I get GNU Grub Version 2.04 appearing with an empty grub> prompt. I tabbed through the options but did not see an “install”. Where do I go from here to install qubes?

I was able to get the installation menu. The problem was that I issued the command “sudo dd if=Qubes-RX-x86_64.iso of=/dev/sdb1 status=progress bs=1048576 conv=fsync” with sdb1 instead of sdb. Once I did that, I got the menu. But, I encountered another issue.

Now, upon boot, I get the boot menu with 5 options:

  1. Install Qubes OS R4.1.2
  2. Test media and install Qubes OS R4.1.2
  3. Troubleshooting -verbose boot and Install Qubes OS R4.1.2
  4. Rescue a Qubes OS system
  5. Install Qubes OS R4.1.2 using kernel-latest (6.1.12-1.qubes.fc32)

Selecting each of the 5 options yields:
error: no multiboot header found.
error: you need to load the kernel first.
error: you need to load the kernel first

Press any key to continue…

I previously had Qubes 4.0 on this machine. How do I continue to installing the latest stable release of qubes?

Now, if I try to edit the first option (select ‘e’), this is what appears:
setparams ‘Install Qubes OS R4.1.2’

multiboot2 /images/pxeboot/xen.gz console=none
module2 /images/pxeboot/vmlinuz inst.stage2=hd:LABEL=QUBES-R4-1-2-X86-64 plymouth.ignore-serial-consoles quiet
module2 /images/pxeboot/initrd.img

Please advise what I should do to continue the installation.

Did you verify your downloaded image? Maybe it’s corrupted:

I verified it with the hash given. What the heck, I will re-download.

SSDD. I re-downloaded the iso, verified the hash, and created the usb via “sudo dd of=/dev/sdb status=progress bs=1048576 conv=fsync” and it still failed with the same result above.

This time, I downloaded the version 4.2 ISO, confirmed the hash and ran the same dd command to create the USB. Same thing. I don’t recall this kind of trouble when I installed version 4.1 so I am thinking it has to do with having qubes already installed. Please, any ideas would be most appeciated.

You can try 4.1 ISO that worked for you previously for a test to see if the issue appeared in recent Qubes version.
You can download older ISOs from here:

While that may reveal the issue is a recent addition, it does not help me as I need to upgrade from my current version 4.0. I need to be able to get to 4.1 or 4.2.

Personally I don’t know why do you have this problem.
If I was in your situation, I would’ve tried the older installer ISO to make sure that it worked and then opened an issue on github to report about this regression between old and new ISO. The test with old ISO is necessary to show the devs that the problem is not with your BIOS configuration or something else which will make old as well as new installer to fail but it’s a clear regression in new installer since the old one works with the same conditions.

try recreate uefi entry in the bios.

Please elaborate. What should it look like?

Same issue while trying to overwrite 4.0 with clean install 4.1.2.
Hashsum is fine, seems there are some GRUB configuration missing or conflict.

Does anyone have any idea?