"Error: no multiboot header found" when installing

Ok, so my in place upgrade crashed at Step 3. I have backups so rather than spend time on troubleshooting the in place upgrade I am doing a clean install.

But, when I try to boot from the USB drive and select any item from the Grub menu I get the following error message:

error: no multiboot header found.
error: you need to load the kernel first.
error: you need to load the kernel first.

This is on a custom built desktop computer with Asus MB, nvidia graphics card, etc. 4.0.4 was running fine on it before. Something about the iso image isn’t right?
what could be going on?

Thanks in advance for your help!


your bootx64.conf or similar file is corrupted

@fiftyfourthparallel, can you spit from this

On the image I downloaded? I should just re-download? thanks @ppc

Let us know if it worked, so I can figure out whether to split the thread or not.

Hi it did work. I just had a corrupted image. I re-downloaded and the install went fine.

Now I feel like I’m getting bugs or something so I need to figure out how to restore my backups and install apps, etc.

A post was merged into an existing topic: Qubes OS 4.1-rc1 has been released!

Hey, you have the same problem as me.
My solution:
1.Check the multiboot segment in bootloader for spelling mistakes(for example: multboot).
2.Check the multiboot segment in the linker.ld.
OK,problem solved now.

Hey @xingchen: How does this work exactly?

Please see here for the issue I have:


Best regards

how to do it ?