Installation freezes after "XEN..." (Nvidia / Dell XPS 15 7590)


I just started using Qubes a couple months ago and I fell in love with it. I am fairly new to Linux so please bare with me. So far the community has been very nice and helpful and i appreciate it.

I have a dell xps 15 i7 nVida graphics card. This laptop does not have legacy mode option and i do not know how to fix that. my previous Qubes installation was also a headache but I had legacy (and no Nvidia just onboard intel graphics). This XPS 15 is giving me a hard time.

When i boot from USB like 5 seconds of the installation goes and it stops at “XEN…” and goes black after that. Im guessing it has something to do with the nvidia so i read that i should add " nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off to kernel by pressing tab to edit bootx64.cfg file. Well the installation doesnt let me get there, the screen goes black before i can press tab or ctrl-a ctrl-t nothing works. So then i tried editing the .cfg file through my host OS Kali and no matter how i tried i cannot save the .cfg file. It says “read only”. i cant even like delete and replace the file.

So i created a Qubes folder in my Grub and copied all the files in EFI and did the noveau…etc replacements above.
XPS 15 BIOS setup page i am able to select boot sequence and i select my installation usb. “file system name” i select the USB. “file name” i select the .bootx64.efi from my grub which has edited info. stil lsame problem…

i am trying to maybe download qubes on my other laptop that i have successfully downloaded qubes on before. install qubes on other laptop SSD then remove SSd and insert into my Dell XPS 15? i tried doing this with external hdd and connected via usb and i was getting emergency mode anacut or initrams command line. something about ueid not matching.

someone please help me this is getting frustrating!!

I don’t know much about this so all I can do is point to resource that could help (but you seem to have already checked at least one of them):

I’ve also fixed some formatting issue on your post (I’m a moderator) and made the title a bit more specific (feel free to change it you feel it does not reflect well the issue at hand).

thanks i appreciate that!

So i figured it out actually. For anyone having this issue do this:

Since i already have one laptop i successfully downloaded qubes on, I took out the SSD for my dell xps 15 and inserted it into my first laptop. I went ahead and installed Qubes using my original laptop with SSD from dell xps 15. After installation i waited until i successfully booted into qubes desktop then shutdown. I then inserted my SSD back into my dell xps 15. The first boot had a couple failures starting VM’s. But it still booted me in and i did a Qubes update restarted the laptop and everything seems fine so far. Just NVIDIA graphics isnt being recognised (i see it in my devices list in a qubes setting but running the HCL hardware test in dom0 it shows only intel graphics).

1 Like