Installation fails when switching to graphical system - Thinkpad P1 Gen 3 (SOLVED)

Hi Forum,

I’m trying to install Qubes 4.2.1 on my Thinkpad P1 Gen3 - its exactly this model but with 64 GB RAM.

I am sure that it can run qubes as I did install it before. Last time I installed it it was 4.0 I think, and I had to add some boot parameters to make it work, which I intelligently did not write down :confused:

I have tried installing 4.2.1 and 4.2.0 and get the same result for both. I tried 4.1 just for the fun of it, which says it cant find the kernel to boot. But thats deprecated anyways.

When booting 4.2.1 (or 4.2.0) I selected the:

  • boot with verify: goes to black screen (does not turn screen off, just black)
  • boot without verify: goes to black screen (same)
  • boot in debug mode: hangs at about starting systemd-journald, or sometimes systemd-somtething-with-tmpfiles, or at uploading xen processor PM info
  • boot latest kernel: I edited the boot params here to remove the “quiet”, which then hangs at the same as the debug boot

I did very extensive checking in the BIOS and tried both hybrid as well as discrete graphics, both had no effect. I also tried everything else that makes sense, and I’m reasonably sure I didn’t miss anything that could be related.

I followed this Installation troubleshooting | Qubes OS and added

 nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off

which didn’t help. I also tried

 noexitboot=1 modprobe.blacklist=nouveau rd.driver.blacklist=nouveau --- intitrd.img


nomodeset ip=dhcp inst.nokill inst.vnc

(from Nvidia Troubleshooting Guide)

which also didn’t help. When the screen goes black, pressing CRTL + ALT + F1-12 doesnt do anything.

Its all a bit weird. Hope you guys have some ideas.

modprobe.blacklist=xen_acpi_processor rd.driver.blacklist=xen_acpi_processor

Github Issue: Qubes 4.2 rc4 Install Fails at “xen_acpi_processor: Uploading Xen processor PM info” · Issue #8635 · QubesOS/qubes-issues (

1 Like

that fixed it, THANK YOU !!! :))