Installation ends with DNF error

Hi folks!

I’m trying to install qubes os for my first time. I followed the instructions on the qubes website and made a USB memory stick on an actual ubunutu linux witd dd as described. Then, I used this USB stick on an intel nuc core i5 for the installation. Setup is starting up with no problems and I can make all the settings necessary for the installation.

After ~1/3 of the installation, the installer shows a Window with the error message: «Der folgende schwerwiegende Fehler trat während der Installation auf. Hierbei handelt es sich um einen schwerwiegenden Fehler und die Installation wird abgebrochen.

DNF error: Error unpacking rpm package qubes-template-debian-10-4.0.1-201912251612.noarch»

After terminating the installation, I can only choose to start over again (what I did once with the same error on the same spot).

Can you help me how I can solve this fault and proceed with a complete installation?

Kind regards,


1 Like

Hi @dominic ,

it’s not a common error, did you see another useful details around the DNF error line ?

Which iso? 4.0.3, 4.0.4-rc2 (or 4.1-alpha) ?

Is the disk size enough?

Disk size was my immediate thought.
Did you verify the install media? make sure that there were no errors on
creating the medium?
I would try recreating the USB, after confirming that you have a good
image downloaded.

Hi @ludovic

I am using the 4.0.3 version.

The distri download was verified and ok. But I made the memory stick new (with the same steps as bevore) and finally, the installation worked :slight_smile:

Thanks a lot for the support!


1 Like

Good news, welcome to Qubes world :slight_smile:

The Qubes OS documentation contains a lot of very useful documentation.

Follow also the Qubes OS news, the github issue tickets, and the Invisible Things blog.