[Install media] Black screen at boot


I copied the qubes4.0.3 iso to a 16Gb Sandisk USB drive and when I boot from the USB drive I see some console text for 2 seconds and then the screen goes black and get stuck there.

Specs :
Custom build PC
motherboard : ASUS x470 PRIME
CPU : AMD Ryzen 5 2600
Graphic card EVGA GTX 1060
RAM : 16GB

I use Fedora 31.
This thread is pretty much a continuation of this reddit thread I started.

I’m desperate to find a solution. I tried many thing like editing bootx64.cfg and accessing to grub(I cannot).

So I followed all the official installation guide, installed key and verified signatures. I used this command to copy the iso on the USB drive.

sudo dd if=Qubes-R4.0.3-x86_64.iso of=/dev/sdY status=progress bs=1048576 && sync

So after some reading on github I found that I have to edit BOOTX64.cfg, but it’s read only.

chmod -rw does not works, I tried the method in the guide https://www.qubes-os.org/doc/uefi-troubleshooting/.

parted Qubes-R4.0-rc4-x86_64.iso unit B print


sudo losetup -o 524288 --sizelimit 30562304 /dev/loop0 Qubes-R4.0-rc4x86_64.iso

I tried that manners , I tried to edit the file with xed, but it still says it’s read only file system.

I have no idea what to do now.

Hope you got ideas.

Thank you for reading.

First thoughts 16GB is quite small. Second thoughts, could be the GPU. What model is your PC/Laptop? How much RAM? Can you plug the USB into another standard machine with no GPU to see if it works?

Its a custom build PC with 16 GB RAM, no model.

I already checked solutions for GPU problems, nothing helped me. They all implies to access GRUB, which I cannot access since I get nothing but a black screen. Holding ETC or SHIFT or TAB does not make GRUB menu appears.
Editing bootx64 or grub or anything inside the Qubes ISO is also unsuccessful, only give blackscreen.

I don’t have any machine with no GPU.

Qubes is very fussy wrt hardware. I’m not technical enough to know how to get around these issues, but they are very common.

I managed to install Qubes OS, but trough a virtualmachine. I did not found a solution for the USB boot problem.

A note on this: on the hardware requirements it says there the following:

:warning: Note: Qubes OS is not meant to be installed inside a virtual machine as a guest hypervisor. In other words, nested virtualization is not supported. In order for a strict compartmentalization to be enforced, Qubes OS needs to be able to manage the hardware directly.

Read more:

I did not install QubesOS inside a virtual machine, but through a virtual machine. Instead of using a virtual disk, I created a fake vitrual disk with this command :

VBoxManage internalcommands createrawvmdk -filename "C:Users<user_name>VirtualBox VMs<VM_folder_name><file_name>.vmdk" -rawdisk .PhysicalDrive#

Where # is the drive wanted. I lunched the iso as a media and during installation, Qubes OS detected the empty free space on my disk and I choose the auto setup for mounting point. It worked perfectly. Now I have a independent QubesOS on its own crypted partition. Qubes is not running inside a virtual machine it was just for installation to disk. A nice trick.


Oh, I see. That makes sense. Apologies for the misinterpretation. And thanks for the tech tip!

What configuration did you use in Virtual Box: paravirtualization etc.? I’m trying this route and also tested with Hyper V but in both cases the installer runs into page fault issues and breaks earlier even than the black screen.

I used default paravertualization. Be sure to enable VT-x or AMD-V and IOMMU ins your BIOS setting.

here is picture of my config.

Thanks for the input! I’ve fiddled around with these settings but unfortunately I’ve realized the problem is probably due to my Ryzen 4900 which only has experimental support:

I’ll probably need to wait for Qubes 4.1 and try it once it arrives.