Install fails on Dell Latitude E7270

Hello folks,

I’ve tried to install Qubes-R4.0.4-x86_64.iso on a Dell Latitude E7270 but couldn’t get it working.
I would appreciate your help a lot!

This is what I’ve done to create the installation medium:

  1. Download the iso file
  2. Verify signatures and filehash
  3. Use a 64 GB USB 3 drive
  4. sudo dd if=Qubes-R4.0.4-x86_64.iso of=/dev/sdb status=progress bs=1M && sync
    ( I know, I changed the bs parameter, but it shouldn’t make a difference )
  5. Everything works fine

The install process, using UEFI:

  1. Start laptop
  2. F12 to open boot menu
  3. select UEFI (secure boot disabled) → my USB device
  4. some boot messages appear, anaconda appears, I select a language (us)
  5. click install medium → verify → “This medium looks not good”
    ( How can I find out why the verification fails ? Can I do it manually? )
  6. I can install anyway, so I do
  7. While installing, at step 946, it fails with an exception “DNF error: Error unpacking rpm package qubes -template-fedora…”

The medium either is really corrupt or my laptop has a malfunction.

So I tried the legacy boot option (csm):

  1. boot laptop
  2. legacy boot from usb
  3. installer menu appears (I got to select between install qubes and verify and install)
  4. I choose Verify and Install Qubes
  5. The grey screen appears, a loading bar appears
  6. After ~30% of the progress it freezes. No further progress

I also tried several USB ports and updated my BIOS to latest version.
Important BIOS settings also have been set: intel vt-d/tpm 1.2/ intel vt-x

The usb device is new.

OP here…

After creating the seventh USB device, I finally found a solution to the media verification fail (UEFI):

the dd bs parameter seems to make a difference. The verification works now. Strange. Isn’t it?

On the official installation guide it’s recommended bs=1048576. Was that what you used?

@deeplow Yes. Before that, I’ve used bs=1M because 1048576 = 1M. But surprisingly enough it makes a difference.

1 Like

I had experienced exactly the same in the past.